summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rw-r--r--fallingtime.desktop9
-rw-r--r--fallingtime.sh3
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..878b11a1c8b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = fallingtime
+ pkgdesc = Arcade game inspired by Fall Down. SDL 2, PC or OpenDingux.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/cxong/FallingTime
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ conflicts = fallingtime-git
+ source = fallingtime-1.0.2.zip::https://github.com/cxong/FallingTime/archive/refs/tags/1.0.2.zip
+ source = fallingtime.sh
+ source = fallingtime.desktop
+ sha256sums = cbfde4c192dee6a5f7bf2f8e975a87a3af01efc8acbf011fc0e17741726a894e
+ sha256sums = 2213caa4bb13f483b61a6ea57ee0f74394080505720d004a476ed10651150fc7
+ sha256sums = e7c80c605000bedabb5cd0c415539288f2a3cc01246e84364dbdac2742a81414
+
+pkgname = fallingtime
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52e56b6c6424
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+
+pkgname=fallingtime
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Arcade game inspired by Fall Down. SDL 2, PC or OpenDingux."
+arch=('any')
+url="https://github.com/cxong/FallingTime"
+license=('GPL2')
+makedepends=('git' 'cmake')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
+source=("${pkgname}-${pkgver}.zip::https://github.com/cxong/FallingTime/archive/refs/tags/${pkgver}.zip"
+ "${pkgname}.sh"
+ "${pkgname}.desktop")
+sha256sums=('cbfde4c192dee6a5f7bf2f8e975a87a3af01efc8acbf011fc0e17741726a894e'
+ '2213caa4bb13f483b61a6ea57ee0f74394080505720d004a476ed10651150fc7'
+ 'e7c80c605000bedabb5cd0c415539288f2a3cc01246e84364dbdac2742a81414')
+
+conflicts=(${pkgname}-git)
+
+prepare() {
+ mv "${srcdir}/FallingTime-${pkgver}" "${srcdir}/${pkgname}-${pkgver}"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake .
+ make
+}
+
+package() {
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/COPYRIGHT" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install "${srcdir}/${pkgname}-${pkgver}/falling_time" -Dm755 "${pkgdir}/opt/${pkgname}/${pkgname}"
+ cp -r "${srcdir}/${pkgname}-${pkgver}/data" "${pkgdir}/opt/${pkgname}/"
+ install "${startdir}/${pkgname}.sh" -Dm755 "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${startdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/fallingtime.desktop b/fallingtime.desktop
new file mode 100644
index 000000000000..b0c39fcea21f
--- /dev/null
+++ b/fallingtime.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+
+Name=Falling Time
+Comment=Arcade game inspired by Fall Down.
+Exec=fallingtime
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=games;
diff --git a/fallingtime.sh b/fallingtime.sh
new file mode 100644
index 000000000000..f70e666d5cf1
--- /dev/null
+++ b/fallingtime.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/fallingtime
+./fallingtime