summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09d67c814c1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fang
+ pkgdesc = A multi service threaded MD5 cracker
+ pkgver = git
+ pkgrel = 3
+ url = https://github.com/evilsocket/fang
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = python2
+ backup = etc/fang.conf
+ source = git+https://github.com/evilsocket/fang
+ md5sums = SKIP
+
+pkgname = fang
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d23f9f09ddc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ari Mizrahi <codemunchies at debugsecurity dot com>
+# Contributor: ArchAssault Project <https://www.archassault.org>
+
+pkgname=fang
+pkgver=git
+pkgrel=3
+pkgdesc="A multi service threaded MD5 cracker"
+arch=('any')
+url=('https://github.com/evilsocket/fang')
+license=('GPL2')
+makedepends=('git')
+depends=('python2')
+source=('git+https://github.com/evilsocket/fang')
+md5sums=('SKIP')
+backup=('etc/fang.conf')
+
+prepare() {
+ cd "$srcdir/fang"
+
+ # Follow standards, put config files in /etc.
+ sed -i 's|fang\.conf|/etc/fang.conf|' fang.py
+
+ # Fix shebang header.
+ sed -i 's|python$|python2|' fang.py
+}
+
+package() {
+ cd "$srcdir/fang"
+
+ install -dm755 "$pkgdir/etc"
+ install -dm755 "$pkgdir/usr/bin"
+
+ install -m755 fang.py "$pkgdir/usr/bin/fang"
+ install -m644 fang.conf "$pkgdir/etc/fang.conf"
+}