summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rw-r--r--fatcalc.desktop9
-rw-r--r--fatcalc.pngbin0 -> 2342 bytes
-rw-r--r--fatcalc.sh7
5 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0863f2c940bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 13:09:02 UTC 2015
+pkgbase = fatcalc
+ pkgdesc = Body fat calculator
+ pkgver = 1.1.1.32
+ pkgrel = 2
+ url = http://sourceforge.net/projects/fatcalc
+ arch = any
+ license = GPL
+ depends = java-environment
+ source = http://downloads.sourceforge.net/project/fatcalc/fatcalc-1.1.1.32-bin.tar.gz
+ source = fatcalc.sh
+ source = fatcalc.desktop
+ source = fatcalc.png
+ md5sums = 8c2b0563446cfc66d8b7fcd0530e4ec6
+ md5sums = ac0b8ea7315a454890c41e4e11350709
+ md5sums = 7e2e2ae108235d6d8b402726b5cd967a
+ md5sums = 3d62bb2e80ec7c1cdb0f5a842b1abf27
+
+pkgname = fatcalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a5b787fb878
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Eric Ozwigh <ozwigh at gmail dot com>
+# Contributor: Baobab <eternal.baobab@gmail.com>
+
+pkgname=fatcalc
+pkgver=1.1.1.32
+pkgrel=2
+pkgdesc="Body fat calculator"
+arch=('any')
+url="http://sourceforge.net/projects/fatcalc"
+license=('GPL')
+depends=("java-environment")
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname-${pkgver}-bin.tar.gz"
+ "$pkgname.sh"
+ "$pkgname.desktop"
+ "$pkgname.png")
+md5sums=('8c2b0563446cfc66d8b7fcd0530e4ec6'
+ 'ac0b8ea7315a454890c41e4e11350709'
+ '7e2e2ae108235d6d8b402726b5cd967a'
+ '3d62bb2e80ec7c1cdb0f5a842b1abf27')
+
+package() {
+ install -d $pkgdir/usr/share/java/$pkgname
+ install -m644 $srcdir/$pkgname.jar $pkgdir/usr/share/java/$pkgname
+ install -D -m755 $srcdir/$pkgname.sh $pkgdir/usr/bin/$pkgname
+ install -D -m644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -D -m644 $pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -D -m644 $srcdir/readme.txt $pkgdir/usr/share/doc/$pkgname/readme.txt
+}
diff --git a/fatcalc.desktop b/fatcalc.desktop
new file mode 100644
index 000000000000..b3e0b6ed64ae
--- /dev/null
+++ b/fatcalc.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=FatCalc
+Comment=simple body fat calculator
+Icon=fatcalc
+Exec=fatcalc
+Categories=Office;
+Terminal=false
+Type=Application
diff --git a/fatcalc.png b/fatcalc.png
new file mode 100644
index 000000000000..69ddef301d71
--- /dev/null
+++ b/fatcalc.png
Binary files differ
diff --git a/fatcalc.sh b/fatcalc.sh
new file mode 100644
index 000000000000..993d45014455
--- /dev/null
+++ b/fatcalc.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for jar in /usr/share/java/fatcalc/*.jar; do
+ CP=$CP:$jar
+done
+
+java -cp $CP net.sourceforge.fatcalc.Main