summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
-rw-r--r--fbview.install6
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..277e02979835
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Jan 7 19:59:04 UTC 2016
+pkgbase = fbview
+ pkgdesc = small framebuffer document viewer for pdf and djvu
+ pkgver = 1.0
+ pkgrel = 1
+ url = github.com/oaken-source/fbview
+ install = fbview.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = mupdf
+ optdepends = poppler: alternative .pdf support,
+ optdepends = djvulibre: .djvu support
+ source = http://files.grapentin.org/fbview/fbview-1.0.tar.gz
+ md5sums = fa307f8db0438f29d792733f76ea648b
+
+pkgname = fbview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdb9f8b8a06c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andreas Grapentin <andreas@grapentin.org>
+pkgname=fbview
+pkgver=1.0
+pkgrel=1
+pkgdesc="small framebuffer document viewer for pdf and djvu"
+arch=('i686' 'x86_64')
+url="github.com/oaken-source/fbview"
+license=('BSD')
+depends=('mupdf')
+optdepends=('poppler: alternative .pdf support', 'djvulibre: .djvu support')
+install='fbview.install'
+source=("http://files.grapentin.org/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('fa307f8db0438f29d792733f76ea648b')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/fbview.install b/fbview.install
new file mode 100644
index 000000000000..ffb1eec438b2
--- /dev/null
+++ b/fbview.install
@@ -0,0 +1,6 @@
+post_install(){
+ echo "==> fbview in ONLY intended to be used in a framebuffer from the TTY"
+ echo " and will NOT be working anywhere else. if you don't know what this"
+ echo " means, you should probably be using a different viewer."
+ echo ""
+}