summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD54
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd0814fb50e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ff-password-exporter-appimage
+ pkgdesc = Easily export your passwords from Firefox.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/kspearrin/ff-password-exporter
+ arch = x86_64
+ license = GPL
+ noextract = ff-password-exporter-appimage-1.2.0.AppImage
+ options = !strip
+ source_x86_64 = ff-password-exporter-appimage-1.2.0.AppImage::https://github.com/kspearrin/ff-password-exporter/releases/download/v1.2.0/FF-Password-Exporter-1.2.0-x86_64.AppImage
+ source_x86_64 = https://raw.githubusercontent.com//kspearrin/ff-password-exporter/v1.2.0/LICENSE.txt
+ sha256sums_x86_64 = 05f346239391ee5ec13ca73cf05aff0e03455709756896bd3e331b28c713568f
+ sha256sums_x86_64 = 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903
+
+pkgname = ff-password-exporter-appimage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f54980a4c62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: grant0417 <grant0417 at protonmail dot com>
+
+_pkgname=ff-password-exporter
+pkgname=ff-password-exporter-appimage
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Easily export your passwords from Firefox."
+arch=('x86_64')
+url="https://github.com/kspearrin/ff-password-exporter"
+license=('GPL')
+options=(!strip)
+_appimage="${pkgname}-${pkgver}.AppImage"
+source_x86_64=("${_appimage}::https://github.com/kspearrin/ff-password-exporter/releases/download/v${pkgver}/FF-Password-Exporter-${pkgver}-x86_64.AppImage"
+ "https://raw.githubusercontent.com//kspearrin/ff-password-exporter/v${pkgver}/LICENSE.txt"
+ )
+noextract=("${_appimage}")
+sha256sums_x86_64=('05f346239391ee5ec13ca73cf05aff0e03455709756896bd3e331b28c713568f'
+ '8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903')
+
+
+prepare() {
+ chmod +x "${_appimage}"
+ ./"${_appimage}" --appimage-extract
+}
+
+build() {
+ # Adjust .desktop so it will work outside of AppImage container
+ sed -i -E "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${_pkgname}|"\
+ "squashfs-root/${_pkgname}.desktop"
+ # Fix permissions; .AppImage permissions are 700 for all directories
+ chmod -R a-x+rX squashfs-root/usr
+}
+
+package() {
+ # AppImage
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
+ install -Dm644 "${srcdir}/LICENSE.txt" "${pkgdir}/opt/${pkgname}/LICENSE"
+
+ # Desktop file
+ install -Dm644 "${srcdir}/squashfs-root/${_pkgname}.desktop"\
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # Icon images
+ install -dm755 "${pkgdir}/usr/share/"
+ cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Symlink license
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ ln -s "/opt/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}