summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--LICENSE9
-rwxr-xr-xPKGBUILD12
-rwxr-xr-xUNREDISTRIBUTABLE.txt2
4 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6546b3f5f29..96e20afd5e4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
# Generated by mksrcinfo v8
-# Wed May 31 22:16:06 UTC 2017
+# Wed May 31 22:25:49 UTC 2017
pkgbase = ffmpeg-full-git
pkgdesc = Record, convert and stream audio and video (Git version with all possible libs)
- pkgver = N.86313.g87bddba43b
- pkgrel = 6
+ pkgver = N.86329.ga47273c803
+ pkgrel = 1
url = http://www.ffmpeg.org/
arch = i686
arch = x86_64
- license = GPL3
- license = custom:UNREDISTRIBUTABLE
+ license = custom:nonfree and unredistributable
makedepends = git
makedepends = yasm
makedepends = opencl-headers
@@ -115,9 +114,9 @@ pkgbase = ffmpeg-full-git
conflicts = ffmpeg-full-nvenc
conflicts = ffmpeg-libfdk_aac
source = ffmpeg-full-git::git://source.ffmpeg.org/ffmpeg.git
- source = UNREDISTRIBUTABLE.txt
+ source = LICENSE
sha256sums = SKIP
- sha256sums = e0c1b126862072a71e18b9580a6b01afc76a54aa6e642d2c413ba0ac9d3010c4
+ sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
depends_x86_64 = cuda
depends_x86_64 = nvidia-utils
optdepends_x86_64 = intel-media-sdk: for Intel QSV support (experimental)
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b0bb658ca78c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+This software is nonfree and unredistributable.
+
+The end-user must compile this software for himself in order to be allowed to use it.
+
+This software cannot be redistributed.
+
+This software cannot be used commercially.
+
+Due to the libraries used to compile this software, the resulting binaries and libraries are under a complex and restrictive license mix.
diff --git a/PKGBUILD b/PKGBUILD
index ce364768c1e8..c198e582f837 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=ffmpeg-full-git
-pkgver=N.86313.g87bddba43b
-pkgrel=6
+pkgver=N.86329.ga47273c803
+pkgrel=1
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
url="http://www.ffmpeg.org/"
-license=('GPL3' 'custom:UNREDISTRIBUTABLE')
+license=('custom:nonfree and unredistributable')
depends=(
# official repositories:
'glibc' 'alsa-lib' 'jack' 'libpng'
@@ -43,9 +43,9 @@ conflicts=(
'ffmpeg' 'ffmpeg-git' 'ffmpeg-full' 'ffmpeg-full-extra' 'ffmpeg-full-nvenc'
'ffmpeg-libfdk_aac')
source=("$pkgname"::'git://source.ffmpeg.org/ffmpeg.git'
- 'UNREDISTRIBUTABLE.txt')
+ 'LICENSE')
sha256sums=('SKIP'
- 'e0c1b126862072a71e18b9580a6b01afc76a54aa6e642d2c413ba0ac9d3010c4')
+ '04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
pkgver() {
cd "$pkgname"
@@ -194,5 +194,5 @@ package() {
make DESTDIR="$pkgdir/" install
install -D -m755 tools/qt-faststart "${pkgdir}/usr/bin/qt-faststart"
- install -D -m644 "${srcdir}/UNREDISTRIBUTABLE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/UNREDISTRIBUTABLE.txt"
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/UNREDISTRIBUTABLE.txt b/UNREDISTRIBUTABLE.txt
deleted file mode 100755
index ec737d955d96..000000000000
--- a/UNREDISTRIBUTABLE.txt
+++ /dev/null
@@ -1,2 +0,0 @@
-This package, although built from GPL sources, is linked against non-GPL
-libraries and thus cannot be redistributed in binary form.