summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33e930cb2128..0c4280911535 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = file-commander-git
pkgdesc = Qt-based cross-platform Total Commander-like orthodox file manager for Windows, Mac and Linux
- pkgver = 0.9.4.12.471.r0.g42c8aa5
+ pkgver = 0.9.5.2.r11.g4986365
pkgrel = 1
url = https://github.com/VioletGiraffe/file-commander
arch = i686
@@ -8,6 +8,7 @@ pkgbase = file-commander-git
license = GPL3
makedepends = qt5-tools
makedepends = hunspell
+ makedepends = git
depends = qt5-base
optdepends = hunspell
provides = file-commander
@@ -28,4 +29,3 @@ pkgbase = file-commander-git
sha256sums = SKIP
pkgname = file-commander-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b799f38dcb60..3a0de5e69119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=file-commander-git
_pkgname=file-commander
-pkgver=0.9.4.12.471.r0.g42c8aa5
+pkgver=0.9.5.2.r11.g4986365
pkgrel=1
pkgdesc='Qt-based cross-platform Total Commander-like orthodox file manager for Windows, Mac and Linux'
arch=('i686' 'x86_64')
url="https://github.com/VioletGiraffe/file-commander"
license=('GPL3')
depends=('qt5-base')
-makedepends=('qt5-tools' 'hunspell')
+makedepends=('qt5-tools' 'hunspell' 'git')
optdepends=('hunspell')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -33,13 +33,14 @@ pkgver() {
prepare(){
cd "$srcdir/${pkgname%-git}"
+git config --local protocol.file.allow always
git submodule init
for submodule in cpp-template-utils cpputils github-releases-autoupdater \
image-processing qtutils text-encoding-detector; do
git config submodule.${submodule}.url "$srcdir/${submodule}"
done
- git submodule update
-
+ git submodule--helper update
+
# Fix icon name
sed -i 's/Icon=icon/Icon=file-commander/g' qt-app/file_commander.desktop
}