summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--mozilla-1701089.patch33
3 files changed, 47 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2141827da3f1..0b6d118300c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Apr 2 22:57:53 UTC 2021
+# Sun Apr 18 12:37:18 UTC 2021
pkgbase = firefox-kde-opensuse
pkgdesc = Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE
pkgver = 87.0
- pkgrel = 1
+ pkgrel = 2
url = https://build.opensuse.org/package/show/mozilla:Factory/MozillaFirefox
arch = i686
arch = x86_64
@@ -36,7 +36,6 @@ pkgbase = firefox-kde-opensuse
makedepends = python-zstandard
makedepends = dump_syms
makedepends = gcc>=10.2.1
- depends = mozilla-common
depends = libxt
depends = mime-types
depends = dbus-glib
@@ -88,6 +87,7 @@ pkgbase = firefox-kde-opensuse
source = 0027-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch
source = 0028-Make-elfhack-use-toolchain.patch
source = fix_csd_window_buttons.patch
+ source = mozilla-1701089.patch
md5sums = SKIP
md5sums = 1fd86cc439737c90a5854aab7f85080f
md5sums = a26a061efb4def6572d5b319d657f1d6
@@ -112,6 +112,7 @@ pkgbase = firefox-kde-opensuse
md5sums = 72176c9ee7b2ac4f1bb07ff5ee5fe10b
md5sums = 07770d558b8999b5793794e1551a1309
md5sums = f49ac3b9f5146e33ce587e6b23eb1a86
+ md5sums = 1140834b3911a1f2f862b9587941a6d2
pkgname = firefox-kde-opensuse
diff --git a/PKGBUILD b/PKGBUILD
index 0be967c5fc4f..619d3185e9d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,12 +14,12 @@ _pgo=true
_pkgname=firefox
pkgname=$_pkgname-kde-opensuse
pkgver=87.0
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE"
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
url="https://build.opensuse.org/package/show/mozilla:Factory/MozillaFirefox"
-depends=('mozilla-common' 'libxt' 'mime-types'
+depends=('libxt' 'mime-types'
'dbus-glib' 'hicolor-icon-theme'
'libvpx' 'icu' 'libevent' 'nss>=3.28.3' 'nspr>=4.10.6' 'hunspell'
'sqlite' 'libnotify' 'kmozillahelper' 'ffmpeg' 'gtk3'
@@ -101,6 +101,9 @@ source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
# end
# Fix CSD when globalmenu is active #8
fix_csd_window_buttons.patch
+ # Fix MOZILLA#1701089
+ # vp09 codec string fails when parsing Widevine manifest
+ mozilla-1701089.patch
)
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -158,6 +161,9 @@ prepare() {
# Fix CSD when globalmenu is active #8
patch -Np1 -i "$srcdir"/fix_csd_window_buttons.patch
+ # Fix MOZILLA#1701089
+ patch -Np1 -i "$srcdir"/mozilla-1701089.patch
+
if [ $_pgo ] ; then
# Fix MOZILLA#1516803
# sandbox needs to be built with --param lto-partitions=1 when
@@ -289,4 +295,5 @@ md5sums=('SKIP'
'c8e251f1fc9050cd12173b540baa96f8'
'72176c9ee7b2ac4f1bb07ff5ee5fe10b'
'07770d558b8999b5793794e1551a1309'
- 'f49ac3b9f5146e33ce587e6b23eb1a86')
+ 'f49ac3b9f5146e33ce587e6b23eb1a86'
+ '1140834b3911a1f2f862b9587941a6d2')
diff --git a/mozilla-1701089.patch b/mozilla-1701089.patch
new file mode 100644
index 000000000000..402cd37143da
--- /dev/null
+++ b/mozilla-1701089.patch
@@ -0,0 +1,33 @@
+
+# HG changeset patch
+# User Bryce Seager van Dyk <bvandyk@mozilla.com>
+# Date 1616785560 0
+# Node ID f1e9588ebd82ae88b7c512df16b55bf150ce453a
+# Parent 4afcaf218062ae310f41bd0e1c67e2b6f7d271d3
+Bug 1701089 - Accept "vp09" codec string in Widevine manifest. r=mjf, a=RyanVM
+
+Differential Revision: https://phabricator.services.mozilla.com/D109810
+
+diff --git a/dom/media/gmp/GMPParent.cpp b/dom/media/gmp/GMPParent.cpp
+--- a/dom/media/gmp/GMPParent.cpp
++++ b/dom/media/gmp/GMPParent.cpp
+@@ -884,7 +884,7 @@
+ //
+ // Google's code to parse manifests can be used as a reference for strings
+ // the manifest may contain
+- // https://cs.chromium.org/chromium/src/chrome/common/media/cdm_manifest.cc?l=73&rcl=393e60bfc2299449db7ef374c0ef1c324716e562
++ // https://source.chromium.org/chromium/chromium/src/+/master:components/cdm/common/cdm_manifest.cc;l=74;drc=775880ced8a989191281e93854c7f2201f25068f
+ //
+ // Gecko's internal strings can be found at
+ // https://searchfox.org/mozilla-central/rev/ea63a0888d406fae720cf24f4727d87569a8cab5/dom/media/eme/MediaKeySystemAccess.cpp#149-155
+@@ -892,7 +892,8 @@
+ nsCString codec;
+ if (chromiumCodec.EqualsASCII("vp8")) {
+ codec = "vp8"_ns;
+- } else if (chromiumCodec.EqualsASCII("vp9.0")) {
++ } else if (chromiumCodec.EqualsASCII("vp9.0") || // Legacy string.
++ chromiumCodec.EqualsASCII("vp09")) {
+ codec = "vp9"_ns;
+ } else if (chromiumCodec.EqualsASCII("avc1")) {
+ codec = "h264"_ns;
+