summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
-rwxr-xr-xfirstsnow77
3 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e2572987e8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = firstsnow
+ pkgdesc = Prequel spinoff of the visual novel Twofold, focused on Allison and Eileen’s first months in community college
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://firstsnow.salty-salty-studios.com/
+ arch = any
+ license = custom
+ depends = renpy
+ source = https://dl.salty-salty-studios.com/firstsnow/1.0/[SSS]_First_Snow_v1.0_[linux][382AD630].tar
+ source = firstsnow
+ sha256sums = 722fe8c84d200fdb4f6482ba6b6a51a133144b19c12c436eeb4606f28b840fd3
+ sha256sums = 363899f509c23ec65d563415883959a2a9e887a688cfeafbf6e40ade72dbe58c
+
+pkgname = firstsnow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ac4dbaf9a1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgname=firstsnow
+pkgver=1.0
+pkgrel=1
+pkgdesc="Prequel spinoff of the visual novel Twofold, focused on Allison and Eileen’s first months in community college"
+arch=('any')
+url="https://firstsnow.salty-salty-studios.com/"
+license=('custom')
+depends=('renpy')
+source=('https://dl.salty-salty-studios.com/firstsnow/1.0/[SSS]_First_Snow_v1.0_[linux][382AD630].tar'
+ 'firstsnow')
+sha256sums=('722fe8c84d200fdb4f6482ba6b6a51a133144b19c12c436eeb4606f28b840fd3'
+ '363899f509c23ec65d563415883959a2a9e887a688cfeafbf6e40ade72dbe58c')
+
+prepare() {
+ # Note that this only works on x86_64, but the final package should work on any architecture.
+ ./First\ Snow.AppImage --appimage-extract
+}
+
+package() {
+ install -dm755 "$pkgdir"/usr/share/firstsnow/game
+ install -dm755 "$pkgdir"/usr/share/licenses/firstsnow
+ install -dm755 "$pkgdir"/usr/share/icons
+
+ install -Dm755 firstsnow "$pkgdir"/usr/bin/firstsnow
+ install -Dm644 squashfs-root/firstsnow.desktop "$pkgdir"/usr/share/applications/firstsnow.desktop
+
+ cd squashfs-root/opt/firstsnow
+ install -Dm644 \
+ game/code.rpa \
+ game/dlc_h.rpa \
+ game/presplash.png \
+ game/resources.rpa \
+ game/script_version.txt \
+ game/story.rpa \
+ "$pkgdir"/usr/share/firstsnow/game/
+ install -Dm644 SOUND-CREDITS.txt "$pkgdir"/usr/share/licenses/firstsnow/
+ install -Dm644 game/ui/icon.png "$pkgdir"/usr/share/firstsnow/game/ui/icon.png
+ ln -s ../firstsnow/game/ui/icon.png "$pkgdir"/usr/share/icons/firstsnow.png
+ ln -s ../renpy/renpy "$pkgdir"/usr/share/firstsnow/
+}
diff --git a/firstsnow b/firstsnow
new file mode 100755
index 000000000000..71d3a9671d59
--- /dev/null
+++ b/firstsnow
@@ -0,0 +1,77 @@
+#!/usr/bin/env python2
+
+#@PydevCodeAnalysisIgnore
+
+# This file is part of Ren'Py. The license below applies to Ren'Py only.
+# Games and other projects that use Ren'Py may use a different license.
+
+# Copyright 2004-2019 Tom Rothamel <pytom@bishoujo.us>
+#
+# Permission is hereby granted, free of charge, to any person
+# obtaining a copy of this software and associated documentation files
+# (the "Software"), to deal in the Software without restriction,
+# including without limitation the rights to use, copy, modify, merge,
+# publish, distribute, sublicense, and/or sell copies of the Software,
+# and to permit persons to whom the Software is furnished to do so,
+# subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be
+# included in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
+# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+import os
+import sys
+import warnings
+
+# Functions to be customized by distributors. ################################
+
+# Given the Ren'Py base directory (usually the directory containing
+# this file), this is expected to return the path to the common directory.
+
+def path_to_common(renpy_base):
+ return '/usr/share/renpy/renpy/common'
+
+
+# Given a directory holding a Ren'Py game, this is expected to return
+# the path to a directory that will hold save files.
+
+def path_to_saves(gamedir, save_directory=None):
+ import renpy # @UnresolvedImport
+
+ if save_directory is None:
+ save_directory = renpy.config.save_directory
+ save_directory = renpy.exports.fsencode(save_directory)
+
+ # No save directory given.
+ if not save_directory:
+ return gamedir + "/saves"
+
+ # Otherwise, put the saves in a platform-specific location.
+ xdg_data_home = os.getenv('XDG_DATA_HOME')
+ if xdg_data_home is None or len(xdg_data_home) == 0 or xdg_data_home[0] != '/':
+ home = os.getenv('HOME')
+ xdg_data_home = os.path.join(home, '.local', 'share')
+ return os.path.join(xdg_data_home, "renpy", save_directory)
+
+
+def main():
+ renpy_base = '/usr/share/firstsnow'
+
+ sys.path.append(renpy_base)
+
+ # Ignore warnings that happen.
+ warnings.simplefilter("ignore", DeprecationWarning)
+
+ # Start Ren'Py proper.
+ import renpy.bootstrap
+ renpy.bootstrap.bootstrap(renpy_base)
+
+if __name__ == "__main__":
+ main()