summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8423d257dac..23e3cb20fa93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = fish-pisces-git
pkgdesc = Fish plugin for matching paired symbols
pkgver = 0.7.0.r0.ge45e086
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/laughedelic/pisces
arch = any
groups = fish-plugins
license = LGPL3
+ makedepends = git
depends = fish>=2.3
provides = fish-pisces
conflicts = fish-pisces
- source = fish-pisces-git::git+https://github.com/laughedelic/pisces
- sha512sums = SKIP
+ source = fish-pisces-git::git+https://github.com/laughedelic/pisces?signed
+ validpgpkeys = 5E1F1BC473EC7D07B782F5969E2DCD79D9E0A186
+ sha256sums = SKIP
pkgname = fish-pisces-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e5c01c7530f5..385617b3064b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
-# Maintainer: lmartinez-mirror
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
pkgname=fish-pisces-git
pkgver=0.7.0.r0.ge45e086
-pkgrel=1
+pkgrel=2
pkgdesc="Fish plugin for matching paired symbols"
arch=('any')
url="https://github.com/laughedelic/pisces"
license=('LGPL3')
groups=('fish-plugins')
depends=('fish>=2.3')
+makedepends=('git')
provides=('fish-pisces')
conflicts=('fish-pisces')
-source=("$pkgname::git+$url")
-sha512sums=('SKIP')
+source=("$pkgname::git+$url?signed")
+sha256sums=('SKIP')
+validpgpkeys=('5E1F1BC473EC7D07B782F5969E2DCD79D9E0A186')
-pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+pkgver() {
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
package() {
- cd "$pkgname"
- install -Dm644 conf.d/pisces.fish -t "$pkgdir/etc/fish/conf.d/"
- find functions -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/fish/{}" \;
+ cd "$pkgname"
+ install -Dm 644 conf.d/pisces.fish -t "$pkgdir/usr/share/fish/vendor_conf.d/"
+ find functions -type f -exec install -Dm 644 -t "$pkgdir/usr/share/fish/vendor_functions.d/" '{}' \+
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}
-