summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rw-r--r--flatplat-mod.install4
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a86dc2a485a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Mar 25 07:11:12 UTC 2016
+pkgbase = flatplat-mod
+ pkgdesc = Edited version of the Flat-Plat Gnome Shell theme
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://gnome-look.org/content/show.php/Flat-Plat+Mod?content=174427
+ install = flatplat-mod.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk3>=3.18
+ depends = gtk2
+ depends = gnome-shell>=3.18
+ optdepends = gnome-tweak-tool: activate the theme
+ source = flatplat-mod.tar.gz::http://gnome-look.org/CONTENT/content-files/174427-Flat-Plat%20Mod.tar.gz
+ source = flatplat.tar.gz::https://github.com/nana-4/Flat-Plat/releases/download/3.18.20151025/Flat-Plat-3.18.20151025.tar.gz
+ sha256sums = 6a74bb00adc08f36e18be5947f9c55fe0b2b44c6ed8b3ffb17f469c1352c3481
+ sha256sums = 69d9b570cf0f0844937fd75a669419f0b6db982eec0008c37d109980d35fd522
+
+pkgname = flatplat-mod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03faaa3216d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: CTech <ctech.exe@gmail.com>
+
+pkgname=flatplat-mod
+_submodule=flatplat
+pkgver=0.1
+pkgrel=1
+install="${pkgname}.install"
+pkgdesc="Edited version of the Flat-Plat Gnome Shell theme"
+arch=('i686' 'x86_64')
+url="http://gnome-look.org/content/show.php/Flat-Plat+Mod?content=174427"
+license=('GPL')
+depends=('gtk3>=3.18' 'gtk2' 'gnome-shell>=3.18')
+optdepends=('gnome-tweak-tool: activate the theme')
+source=(
+"$pkgname.tar.gz::http://gnome-look.org/CONTENT/content-files/174427-Flat-Plat%20Mod.tar.gz"
+"$_submodule.tar.gz::https://github.com/nana-4/Flat-Plat/releases/download/3.18.20151025/Flat-Plat-3.18.20151025.tar.gz"
+)
+sha256sums=('6a74bb00adc08f36e18be5947f9c55fe0b2b44c6ed8b3ffb17f469c1352c3481'
+ '69d9b570cf0f0844937fd75a669419f0b6db982eec0008c37d109980d35fd522')
+
+build() {
+ cd "${srcdir}/Flat-Plat Mod"
+ cp -dfr --no-preserve='ownership,mode' * "${srcdir}/Flat-Plat"
+ cd "${srcdir}"
+ rm -rf "Flat-Plat Mod"
+ mv "Flat-Plat" "Flat-Plat Mod"
+}
+
+package() {
+ cd "${srcdir}/Flat-Plat Mod"
+ rm -rfv LICENSE
+ install -dm 755 "${pkgdir}/usr/share/themes/Flat-Plat Mod"
+ cp -drv --no-preserve='ownership,mode' * "${pkgdir}/usr/share/themes/Flat-Plat Mod"
+
+}
diff --git a/flatplat-mod.install b/flatplat-mod.install
new file mode 100644
index 000000000000..61513849a0e3
--- /dev/null
+++ b/flatplat-mod.install
@@ -0,0 +1,4 @@
+post_install() {
+echo "To activate the theme, please install gnome-tweak tool, and enable the shell theme. To install the chrome/chromium theme, open chrome/chromium, and navigate to chrome://extensions then drag the files '/usr/share/themes/Flat-Plat Mod/chrome/Flat-Plat Theme.crx' & '/usr/share/themes/Flat-Plat Mod/chrome/Flat-Plat Scrollbars.crx' into the chrome/chromium window."
+}
+