summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD46
2 files changed, 17 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8361adeab895..bd24dd13820b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flow-causal
pkgdesc = flow causal studio
- pkgver = 0.1.0
- pkgrel = 2
+ pkgver = 0.1.1
+ pkgrel = 3
epoch = 0
url = https://github.com/RalphBariz/flow
install = pkg.install
@@ -11,17 +11,11 @@ pkgbase = flow-causal
license = GPL3
makedepends = dub
makedepends = unzip
- source = flow-base.zip::https://github.com/RalphBariz/flow-base/archive/0.1.0.zip
- source = flow-util.zip::https://github.com/RalphBariz/flow-util/archive/0.1.0.zip
- source = flow-alien.zip::https://github.com/RalphBariz/flow-alien/archive/0.1.0.zip
- source = flow-causal.zip::https://github.com/RalphBariz/flow-causal/archive/0.1.0.zip
+ source = flow-0.1.1.zip::https://codeload.github.com/RalphBariz/flow/zip/v0.1.1
source = web.json
source = causal.json
source = flow-causal.service
- md5sums = 4405289e93df0e71fc00abf1ce104ea0
- md5sums = edd89037b2300464df3176d0f249c32a
- md5sums = eb81517aeff6f13be25d4f9352ea0f54
- md5sums = e75d7530f3bc1fa17909e7bdaf86ade6
+ md5sums = 6f3df3e12c524c5cb1a52d5f0d220f18
md5sums = b92fb60eac286af67f3d9c811ae5959a
md5sums = 60705357a2f2d74107f5570ff41ac2d0
md5sums = 006839636fa061ad5397ae95e2cfe887
diff --git a/PKGBUILD b/PKGBUILD
index 0f5730ba61a0..dadd7e3b1567 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Your Name ralph.bariz@gmail.com
pkgname=flow-causal
-pkgver=0.1.0
-pkgrel=3
+pkgver=0.1.1
+pkgrel=1
epoch=0
pkgdesc="flow causal studio"
arch=('i685' 'x86_64')
@@ -19,18 +19,12 @@ backup=()
options=()
install=pkg.install
changelog=
-source=("flow-base.zip::https://github.com/RalphBariz/flow-base/archive/$pkgver.zip"
- "flow-util.zip::https://github.com/RalphBariz/flow-util/archive/$pkgver.zip"
- "flow-alien.zip::https://github.com/RalphBariz/flow-alien/archive/$pkgver.zip"
- "flow-causal.zip::https://github.com/RalphBariz/flow-causal/archive/$pkgver.zip"
+source=("flow-$pkgver.zip::https://codeload.github.com/RalphBariz/flow/zip/v$pkgver"
"web.json"
"causal.json"
"flow-causal.service")
noextract=()
-md5sums=('4405289e93df0e71fc00abf1ce104ea0'
- 'edd89037b2300464df3176d0f249c32a'
- 'eb81517aeff6f13be25d4f9352ea0f54'
- 'e75d7530f3bc1fa17909e7bdaf86ade6'
+md5sums=('6f3df3e12c524c5cb1a52d5f0d220f18'
'b92fb60eac286af67f3d9c811ae5959a'
'60705357a2f2d74107f5570ff41ac2d0'
'006839636fa061ad5397ae95e2cfe887')
@@ -62,35 +56,21 @@ package() {
cp -Lfr flow-causal.service $pkgdir/usr/lib/systemd/system/flow-causal.service
chmod 644 $pkgdir/usr/lib/systemd/system/flow-causal.service
- # compiling libraries
- mkdir -p dub
- cd dub
+ # unpacking
+ unzip -o -qq flow-$pkgver.zip
+ cd flow-$pkgver
- unzip -o -qq ../flow-base.zip
- dub add-local flow-base-$pkgver
-
- unzip -o -qq ../flow-util.zip
- dub add-local flow-util-$pkgver
-
- unzip -o -qq ../flow-alien.zip
- dub add-local flow-alien-$pkgver
-
+ # compiling
+ dub add-path ./
+ cd causal
+ dub build --build release --force
cd ..
-
- # compiling app
- unzip -o -qq flow-causal.zip
- cd flow-causal-$pkgver
- dub build --build release
- cd bin
+ dub remove-path ./
# putting everything to the right place
+ cd causal/bin
mkdir -p $pkgdir/usr/share/flow-causal/
mkdir -p $pkgdir/usr/bin/
cp -Lfr public $pkgdir/usr/share/flow-causal/
cp -Lfr flow-causal $pkgdir/usr/bin/
-
- # removing library registrations
- dub remove-local ../../dub/flow-base-$pkgver
- dub remove-local ../../dub/flow-util-$pkgver
- dub remove-local ../../dub/flow-alien-$pkgver
}