summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD25
-rw-r--r--config3
-rw-r--r--fluffy-cli.install10
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62da7447a2f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = fluffy-cli
+ pkgdesc = fluffy: a file sharing web app that doesn't suck.
+ pkgver = v1.28.0
+ pkgrel = 1
+ url = https://github.com/chriskuehl/fluffy
+ install = fluffy-cli.install
+ arch = x86_64
+ license = MIT
+ license = custom
+ makedepends = python
+ depends = python
+ depends = python-requests
+ provides = fput
+ provides = fpb
+ conflicts = fput
+ conflicts = fpb
+ source = fluffy::git+https://github.com/chriskuehl/fluffy#tag=v1.28.0
+ source = config
+ sha256sums = SKIP
+ sha256sums = d07312009d79dd92164fa0f37597f2721abcc01089628d85f20fe9fb2ac05f3d
+
+pkgname = fluffy-cli
+ install = fluffy-cli.install
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7e24ae2336b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kevin Kuehler <keur@ocf.berkeley.edu>
+
+_pkgname='fluffy'
+pkgname="$_pkgname-cli"
+pkgver='v1.28.0'
+pkgrel=1
+pkgdesc="fluffy: a file sharing web app that doesn't suck."
+install="$pkgname.install"
+arch=('x86_64')
+url="https://github.com/chriskuehl/$_pkgname"
+license=('MIT' 'custom')
+depends=('python' 'python-requests')
+makedepends=('python')
+provides=('fput' 'fpb')
+conflicts=('fput' 'fpb')
+source=("$_pkgname::git+$url#tag=$pkgver" 'config')
+sha256sums=('SKIP' 'd07312009d79dd92164fa0f37597f2721abcc01089628d85f20fe9fb2ac05f3d')
+
+package() {
+ install="$pkgname.install"
+ cd "$srcdir/$_pkgname/cli"
+ python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 ../../config "$pkgdir/etc/fluffy.json"
+}
diff --git a/config b/config
new file mode 100644
index 000000000000..e18601ed6a49
--- /dev/null
+++ b/config
@@ -0,0 +1,3 @@
+{
+ "server": "https://fluffy.cc"
+}
diff --git a/fluffy-cli.install b/fluffy-cli.install
new file mode 100644
index 000000000000..a9e34a92d694
--- /dev/null
+++ b/fluffy-cli.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo "If you'd like to instead use a different instance (for example, one run"
+ echo "internally by your company), you can specify the --server option."
+ echo
+ echo "To make that permanent, you can create a config file with contents similar to:"
+ echo
+ echo " {"server": "https://fluffy.my.corp"}"
+ echo
+ echo "This file can be placed at either /etc/fluffy.json or ~/.config/fluffy.json."
+}