summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--openssl-dynamic-link.patch (renamed from system-sqlcipher.patch)12
3 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 131eea9b297f..8e340a91226a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fluffychat
pkgdesc = Open. Nonprofit. Cute. Easy to use (matrix) messenger. Secure and decentralized.
pkgver = 1.19.0
- pkgrel = 4
+ pkgrel = 5
url = https://fluffychat.im/
arch = x86_64
arch = aarch64
@@ -18,8 +18,8 @@ pkgbase = fluffychat
provides = fluffychat
conflicts = fluffychat
source = fluffychat-v1.19.0.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v1.19.0.tar.gz
- source = system-sqlcipher.patch
+ source = openssl-dynamic-link.patch
sha256sums = 0fb007f2ed56ee46115606dae5eb2bb9eac238c344caae8d478eb80d71e6295f
- sha256sums = b5b2beb552414e692c4cf6def9d74e8327a968dc15747cc0fb794f226e6633e7
+ sha256sums = 30cabdeb108d7766b55c002978d8ef64df4dfba2e3e7b872de774727afa50730
pkgname = fluffychat
diff --git a/PKGBUILD b/PKGBUILD
index cd8c32e442f3..282d4743ba59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=fluffychat
pkgver=1.19.0
-pkgrel=4
+pkgrel=5
pkgdesc="Open. Nonprofit. Cute. Easy to use (matrix) messenger. Secure and decentralized."
arch=('x86_64' 'aarch64')
url="https://fluffychat.im/"
@@ -30,10 +30,10 @@ provides=("$pkgname")
conflicts=("$pkgname")
source=(
"fluffychat-v${pkgver}.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v${pkgver}.tar.gz"
- "system-sqlcipher.patch"
+ "openssl-dynamic-link.patch"
)
sha256sums=('0fb007f2ed56ee46115606dae5eb2bb9eac238c344caae8d478eb80d71e6295f'
- 'b5b2beb552414e692c4cf6def9d74e8327a968dc15747cc0fb794f226e6633e7')
+ '30cabdeb108d7766b55c002978d8ef64df4dfba2e3e7b872de774727afa50730')
prepare() {
# overriding CMake flags for aarch64 in order to ensure build
@@ -46,9 +46,9 @@ prepare() {
export CFLAGS="${CFLAGS/-fstack-clash-protection/ }"
fi
- cd ${pkgname}-$pkgver
- flutter pub get
- patch --follow-symlinks -p1 -i "${srcdir}/system-sqlcipher.patch" -d .
+ patch --follow-symlinks -p1 -i "${srcdir}/openssl-dynamic-link.patch" -d "${srcdir}/${pkgname}-${pkgver}"
+ pushd "${srcdir}/${pkgname}-${pkgver}"
+ flutter pub get
}
build() {
diff --git a/system-sqlcipher.patch b/openssl-dynamic-link.patch
index 02e17bcc426c..ab3f8716ad9e 100644
--- a/system-sqlcipher.patch
+++ b/openssl-dynamic-link.patch
@@ -1,3 +1,15 @@
+--- ./linux/CMakeLists.txt.orig
++++ ./linux/CMakeLists.txt
+@@ -9,6 +9,9 @@
+ # https://wiki.gnome.org/HowDoI/ChooseApplicationID
+ set(APPLICATION_ID "chat.fluffy.fluffychat")
+
++# dynamically link OpenSSL
++set(OPENSSL_USE_STATIC_LIBS OFF)
++
+ # Explicitly opt in to modern CMake behaviors to avoid warnings with recent
+ # versions of CMake.
+ cmake_policy(SET CMP0063 NEW)
--- ./pubspec.lock.orig
+++ ./pubspec.lock
@@ -1799,10 +1799,10 @@