summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD35
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7d3851cb492
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fnb-git
+ pkgdesc = Tool for packing and unpacking XNB files and managing .tmod file archives
+ pkgver = 0.1.0.r0.g5ac79b1
+ pkgrel = 1
+ url = https://github.com/steviegt6/fnb
+ arch = x86_64
+ license = MIT
+ makedepends = dotnet-sdk-8.0
+ makedepends = git
+ depends = dotnet-runtime-8.0
+ depends = libdeflate
+ depends = zlib
+ options = !strip
+ options = !debug
+ source = git+https://github.com/steviegt6/fnb
+ sha256sums = SKIP
+
+pkgname = fnb-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..debcc040f9d9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.*
+fnb/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70c77749f4a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: ppeb <ppeb@ppeb.me>
+pkgname="fnb-git"
+_pkgname=fnb
+pkgver=0.1.0.r0.g5ac79b1
+pkgrel=1
+pkgdesc="Tool for packing and unpacking XNB files and managing .tmod file archives"
+arch=('x86_64')
+url="https://github.com/steviegt6/fnb"
+license=('MIT')
+depends=('dotnet-runtime-8.0' 'libdeflate' 'zlib')
+makedepends=('dotnet-sdk-8.0' 'git')
+# unified binary dotnet releases break when stripped see https://github.com/dotnet/runtime/issues/54947
+options=('!strip' '!debug')
+source=("git+https://github.com/steviegt6/fnb")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ export DOTNET_CLI_TELEMETRY_OPTOUT=1
+ export DOTNET_NOLOGO=true
+
+ cd "$srcdir/$_pkgname"
+ dotnet publish ./src/Tomat.FNB/Tomat.FNB.csproj /p:PublishSingleFile=true /p:DebugType=None /p:DebugSymbols=false
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ mkdir -p "$pkgdir/usr/bin/"
+ cp -r ./src/Tomat.FNB/bin/Release/net8.0/linux-x64/publish/fnb "$pkgdir/usr/bin"
+}