summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD36
-rwxr-xr-xfofix.desktop11
-rwxr-xr-xfofix.install12
-rw-r--r--fofix.pngbin0 -> 5940 bytes
5 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b14c2ee88a2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = fofix
+ pkgdesc = fretsonfire X (FoFiX). Highly improved version of Frets on Fire
+ pkgver = 3.121
+ pkgrel = 6
+ url = http://code.google.com/p/fofix
+ install = fofix.install
+ arch = any
+ groups = games
+ license = GPL
+ depends = python2
+ depends = python2-pygame
+ depends = python2-opengl
+ depends = python2-numpy
+ depends = python2-imaging
+ depends = pyogg
+ depends = pyvorbis
+ depends = python2-pysqlite
+ depends = libffi
+ replaces = fofix
+ source = http://fofix.googlecode.com/files/fofix-3.121.tar.gz
+ source = fofix.desktop
+ source = fofix.png
+ md5sums = ce63bc8924711ab0c52cebbb1b779d7f
+ md5sums = e26fc0ae8f5ca5d9bdbeb34535bacd9a
+ md5sums = f886a7fdfa7592b50aa9f62901910e03
+
+pkgname = fofix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42ed7ca5458c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: François Magimel <magimel.francois@gmail.com>
+# Contributor: doorknob60 <doorknob60 at gmail dot com>
+
+pkgname=fofix
+pkgver=3.121
+pkgrel=6
+pkgdesc="fretsonfire X (FoFiX). Highly improved version of Frets on Fire"
+url="http://code.google.com/p/fofix"
+arch=(any)
+license=('GPL')
+install=${pkgname}.install
+groups=('games')
+depends=('python2' 'python2-pygame' 'python2-opengl' 'python2-numpy' 'python2-imaging' 'pyogg' 'pyvorbis' 'python2-pysqlite' 'libffi')
+replaces=('fofix')
+source=('http://fofix.googlecode.com/files/fofix-3.121.tar.gz' 'fofix.desktop' 'fofix.png')
+md5sums=('ce63bc8924711ab0c52cebbb1b779d7f' 'e26fc0ae8f5ca5d9bdbeb34535bacd9a' 'f886a7fdfa7592b50aa9f62901910e03')
+
+
+build() {
+install -d $pkgdir/usr/
+install -d $pkgdir/usr/share/
+install -d $pkgdir/usr/share/applications/
+install -d $pkgdir/usr/share/pixmaps/
+install -d $pkgdir/usr/bin/
+install -d $pkgdir/opt/
+cd ${srcdir}
+cp ${startdir}/fofix.desktop ${pkgdir}/usr/share/applications/
+cp ${startdir}/fofix.png ${pkgdir}/usr/share/pixmaps/
+mv ${srcdir}/fofix-3.121 $pkgdir/opt/fofix
+cd $pkgdir/usr/bin/
+echo "#/bin/sh" > fofix
+echo "cd /opt/fofix/src/" >> fofix
+echo "python2 ./FoFiX.py" >> fofix
+chmod +x fofix
+chmod -R 777 $pkgdir/opt/fofix
+}
diff --git a/fofix.desktop b/fofix.desktop
new file mode 100755
index 000000000000..f989109b2d00
--- /dev/null
+++ b/fofix.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=3.121
+Type=Application
+Name=FoFiX
+Comment=A great Guitar Hero clone!
+Exec=/usr/bin/fofix
+Encoding=UTF-8
+Icon=/usr/share/pixmaps/fofix.png
+Categories=Game;ArcadeGame;
+Terminal=false
+StartupNotify=false
diff --git a/fofix.install b/fofix.install
new file mode 100755
index 000000000000..8336ee0d3152
--- /dev/null
+++ b/fofix.install
@@ -0,0 +1,12 @@
+post_install() {
+
+
+echo
+echo "Run 'fofix' to start the game. To add songs to the game, add them to '/opt/fofix/data/songs' (I don't think it works in ~/.fofix/songs anymore)"
+echo
+echo "If it ever doesn't work, try removing ~/.fofix/fofix.ini"
+echo
+echo "3.020 and higher only include the Megalight themes by default. For more themes, go to http://www.fretsonfire.net/forums/viewtopic.php?f=32&t=24976 and add the themes to /opt/fofix/data/themes/"
+}
+
+
diff --git a/fofix.png b/fofix.png
new file mode 100644
index 000000000000..66fc712f4612
--- /dev/null
+++ b/fofix.png
Binary files differ