summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ee286306d45..c485c62acf71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = foosynth-plugin-neo_fft3dfilter-git
pkgdesc = Plugin for Vapoursynth/Avisynth: neo_fft3dfilter (Dual interface for Vapoursynth/Avisynth) (GIT version)
- pkgver = r11.0.g5def131
+ pkgver = 12.0.g23522f5
pkgrel = 1
url = https://github.com/HomeOfAviSynthPlusEvolution/neo_FFT3D
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = foosynth-plugin-neo_fft3dfilter-git
makedepends = tbb
makedepends = avisynthplus
makedepends = vapoursynth
+ options = debug
source = neo_fft3dfilter::git+https://github.com/HomeOfAviSynthPlusEvolution/neo_FFT3D.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ad49f97cca9e..6a226f7cfb67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase="foosynth-plugin-${_plug}-git"
pkgname=("avisynth-plugin-${_plug}-git"
"vapoursynth-plugin-${_plug}-git"
)
-pkgver=r11.0.g5def131
+pkgver=12.0.g23522f5
pkgrel=1
pkgdesc="Plugin for Vapoursynth/Avisynth: ${_plug} (Dual interface for Vapoursynth/Avisynth) (GIT version)"
arch=('x86_64')
@@ -20,24 +20,24 @@ makedepends=('git'
)
source=("${_plug}::git+https://github.com/HomeOfAviSynthPlusEvolution/neo_FFT3D.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d r)"
}
prepare() {
- cd "${_plug}"
- mkdir -p build
+ mkdir -p "${_plug}/build"
}
build() {
cd "${_plug}/build"
- cmake .. \
+ cmake -S .. -B . \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build .
}
package_avisynth-plugin-neo_fft3dfilter-git() {