summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f6576529a7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fourier-motzkin
+ pkgdesc = The FM library allows to project systems of linear inequalities.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = http://web.cse.ohio-state.edu/~pouchet/software/fm
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ source = http://web.cse.ohio-state.edu/~pouchet/software/fm/download/fm-0.5.0.tar.gz
+ md5sums = 0e63380d59931f19643c03ce45c9b76c
+
+pkgname = fourier-motzkin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5bc2aa573e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eadcc86fda2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+
+# This one is taken by another package:
+_pkgname=fm
+
+# So let's use this one instead
+pkgname=fourier-motzkin
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="The FM library allows to project systems of linear inequalities."
+arch=('i686' 'x86_64')
+url="http://web.cse.ohio-state.edu/~pouchet/software/fm"
+license=('LGPL3')
+depends=()
+source=("$url/download/$_pkgname-$pkgver.tar.gz")
+md5sums=('0e63380d59931f19643c03ce45c9b76c')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}