summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bfb7e907a1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fractus-atlas
+ pkgdesc = An image viewer which allows you to quickly move them in folders
+ pkgver = 1.14.0
+ pkgrel = 1
+ url = https://github.com/Jimskapt/fractus-atlas
+ arch = x86_64
+ license = custom
+ makedepends = cargo
+ depends = webkit2gtk
+ source = fractus-atlas-1.14.0.tar.gz::https://github.com/Jimskapt/fractus-atlas/archive/1.14.0.tar.gz
+ sha256sums = a2f736db72d45c09fde16be34b75767639cfc48d1da568c4f5e08548049b1d4f
+
+pkgname = fractus-atlas
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e21776cbdadc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=fractus-atlas
+pkgver=1.14.0
+pkgrel=1
+pkgdesc="An image viewer which allows you to quickly move them in folders"
+url="https://github.com/Jimskapt/fractus-atlas"
+arch=('x86_64')
+license=('custom')
+depends=('webkit2gtk')
+makedepends=('cargo')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Jimskapt/fractus-atlas/archive/${pkgver}.tar.gz")
+sha256sums=('a2f736db72d45c09fde16be34b75767639cfc48d1da568c4f5e08548049b1d4f')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cargo build --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}/target/release"
+ install -Dm755 fractus-atlas "${pkgdir}/usr/bin/fractus-atlas"
+}