summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ecf1d541120..99e4b299e995 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,12 @@ pkgbase = fragments-git
makedepends = libdazzle
makedepends = meson
makedepends = vala
+ depends = curl
depends = gtk3
+ depends = libb64
+ depends = libevent
+ depends = libnatpmp
+ depends = miniupnpc
provides = fragments
conflicts = fragments
source = git+https://github.com/haecker-felix/Fragments.git
diff --git a/PKGBUILD b/PKGBUILD
index a6386dc55ec5..e2af65d4479a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,20 @@ pkgname=$_pkgname-git
pkgver=latest
pkgrel=1
pkgdesc="A GTK3 BitTorrent client following the GNOME Human Interface Guidelines"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+arch=(i686 x86_64 armv6h armv7h)
url="https://github.com/haecker-felix/Fragments"
-license=('GPL3')
-depends=('gtk3')
-makedepends=('git'
- 'gobject-introspection'
- 'libdazzle'
- 'meson'
- 'vala')
+license=(GPL3)
+depends=(curl
+ gtk3
+ libb64
+ libevent
+ libnatpmp
+ miniupnpc)
+makedepends=(git
+ gobject-introspection
+ libdazzle
+ meson
+ vala)
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://github.com/haecker-felix/Fragments.git")
@@ -23,6 +28,7 @@ prepare() {
cd Fragments
git submodule update --init --recursive
}
+
pkgver() {
cd Fragments
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'