summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--frappe-books.sh10
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 676a0fe33995..0ad7f367ee6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = frappe-books-bin
pkgdesc = Modern desktop accounting for freelancers and small-businesses.
pkgver = 0.21.2
- pkgrel = 2
+ pkgrel = 3
url = https://frappebooks.com/
arch = x86_64
license = AGPL-3.0-only
@@ -14,6 +14,6 @@ pkgbase = frappe-books-bin
source = frappe-books-0.21.2.deb::https://github.com/frappe/books/releases/download/v0.21.2/frappe-books_0.21.2_amd64.deb
source = frappe-books.sh
sha256sums = 4d1004552528005e2eda881dc0353fead565a8b9c4cc194f9a045f820d39ae86
- sha256sums = 4e61e7cfc13404def7b48f257a0a0dfc4aec3ec2edb6e33a01eeb43020afa74f
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = frappe-books-bin
diff --git a/PKGBUILD b/PKGBUILD
index 07bc9c469f9f..6f62453d71e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=frappe-books-bin
_pkgname="Frappe Books"
pkgver=0.21.2
_electronversion=22
-pkgrel=2
+pkgrel=3
pkgdesc="Modern desktop accounting for freelancers and small-businesses."
arch=('x86_64')
url="https://frappebooks.com/"
@@ -24,13 +24,14 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('4d1004552528005e2eda881dc0353fead565a8b9c4cc194f9a045f820d39ae86'
- '4e61e7cfc13404def7b48f257a0a0dfc4aec3ec2edb6e33a01eeb43020afa74f')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin}|g;s|Finance|Utility|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
diff --git a/frappe-books.sh b/frappe-books.sh
index d488bdc61bd2..7ddcaab8d734 100644
--- a/frappe-books.sh
+++ b/frappe-books.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
-_RUNNAME="${_APPDIR}/resources/@runname@"
+_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file