summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7aa7456696ea..3b35cf2a8eac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = freeblocks-git
pkgdesc = Tetris Attack-like puzzle game
- pkgver = r181.g68b11ed
- pkgrel = 1
+ pkgver = r193.gfa7088c
+ pkgrel = 2
url = https://github.com/dorkster/freeblocks
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a90681413850..817a9ac79908 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
+# Maintainer: Christoph J. Thompson <thompsonc at protonmail dot ch>
pkgname=freeblocks-git
-pkgver=r181.g68b11ed
-pkgrel=1
+pkgver=r193.gfa7088c
+pkgrel=2
pkgdesc="Tetris Attack-like puzzle game"
arch=('i686' 'x86_64')
url="https://github.com/dorkster/freeblocks"
@@ -24,7 +24,9 @@ pkgver() {
build() {
cd "${pkgname}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cmake \
+ -DCMAKE_C_FLAGS="${CFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=/usr .
make
}
@@ -32,4 +34,3 @@ package() {
cd "${pkgname}"
make DESTDIR="${pkgdir}" install
}
-