summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD25
-rw-r--r--qt5.11.patch310
-rw-r--r--remove-qtwebkit.patch27
4 files changed, 337 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5381a337ba2..0f1c0c5a62ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = freecad
pkgdesc = A general purpose 3D CAD modeler
pkgver = 0.17
- pkgrel = 5
+ pkgrel = 6
url = http://www.freecadweb.org/
arch = x86_64
license = LGPL
@@ -13,43 +13,46 @@ pkgbase = freecad
makedepends = desktop-file-utils
makedepends = cmake
makedepends = coin>=3.1.3-9
- makedepends = python2-pyside
+ makedepends = python2-pyside2
+ makedepends = pyside2
+ makedepends = shiboken2
depends = boost-libs
depends = curl
depends = opencascade>=7.2
depends = xerces-c
depends = libspnav
depends = glu
+ depends = netcdf
depends = shared-mime-info
depends = hicolor-icon-theme
depends = jsoncpp
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-svg
+ depends = qt5-tools
depends = med
- depends = qt4
- depends = netcdf
depends = python2-pivy
- depends = python2-pyside
+ depends = python2-pyside2
depends = python2-matplotlib
- depends = python2-shiboken
- depends = python2-pyside-tools
- depends = pyside-tools-common
+ depends = pyside2-tools
optdepends = python2-matplotlib
- optdepends = python2-pyqt4
+ optdepends = python2-pyqt5
optdepends = graphviz
optdepends = openscad
source = freecad-0.17.tar.gz::https://github.com/FreeCAD/FreeCAD/archive/0.17.tar.gz
source = freecad-84d6128-rollup.patch::https://github.com/FreeCAD/FreeCAD/compare/0.17...84d6128.patch
source = freecad.desktop
source = freecad.xml
- source = remove-qtwebkit.patch
source = gcc8.patch
source = smesh-pthread.patch
+ source = qt5.11.patch
sha256sums = ae017393476b6dc7f1192bcaf91ceedc2f9b791f2495307ce7c45efadb5266fb
sha256sums = c4a4e084da448c78644e8acc1f3158cf2cb82ee4936b5b79e282497fd62d566e
sha256sums = 617968d7bbd1da71bdedaed1b66c5d6eaf24e0fb34678b93f5d925d370c66296
sha256sums = 248918de7d3c2145b5cc4fbbc9e224d22f4a6ca7ead2680e8c3a32e91772482a
- sha256sums = de214a281d421d44b02b469ecf72e36c4d61f10c40431e511e09734aca316baf
sha256sums = 618bb85c4f3a4eb0e329d1fc30391b777c9b0cffe97aa1e96d45f58b18424311
sha256sums = 170c90ee6ef64cf3c8e6a35ca94bb1187d346707f7e0779022e614563c6b74f6
+ sha256sums = a639c9d51f8443e4d2270fe60d5ac3ac62c7c64c532620108514840f8e8704bc
pkgname = freecad
diff --git a/PKGBUILD b/PKGBUILD
index 328d6bd4e794..70db9585f3ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,37 +10,36 @@
pkgname=freecad
pkgver=0.17
_rollup=84d6128
-pkgrel=5
+pkgrel=6
pkgdesc='A general purpose 3D CAD modeler'
arch=('x86_64')
url='http://www.freecadweb.org/'
license=('LGPL')
-depends=('boost-libs' 'curl' 'opencascade>=7.2' 'xerces-c' 'libspnav' 'glu'
- 'shared-mime-info' 'hicolor-icon-theme' 'jsoncpp' 'med' 'qt4' 'netcdf'
- 'python2-pivy' 'python2-pyside' 'python2-matplotlib' 'python2-shiboken'
- 'python2-pyside-tools' 'pyside-tools-common')
-makedepends=('boost' 'eigen' 'gcc-fortran' 'swig' 'xerces-c'
- 'desktop-file-utils' 'cmake' 'coin>=3.1.3-9' 'python2-pyside')
-optdepends=('python2-matplotlib' 'python2-pyqt4' 'graphviz' 'openscad')
+depends=('boost-libs' 'curl' 'opencascade>=7.2' 'xerces-c' 'libspnav' 'glu' 'netcdf'
+ 'shared-mime-info' 'hicolor-icon-theme' 'jsoncpp' 'qt5-base' 'qt5-declarative' 'qt5-svg' 'qt5-tools'
+ 'med' 'python2-pivy' 'python2-pyside2' 'python2-matplotlib' 'pyside2-tools')
+makedepends=('boost' 'eigen' 'gcc-fortran' 'swig' 'xerces-c' 'desktop-file-utils'
+ 'cmake' 'coin>=3.1.3-9' 'python2-pyside2' 'pyside2' 'shiboken2')
+optdepends=('python2-matplotlib' 'python2-pyqt5' 'graphviz' 'openscad')
source=("$pkgname-$pkgver.tar.gz::https://github.com/FreeCAD/FreeCAD/archive/$pkgver.tar.gz"
"$pkgname-$_rollup-rollup.patch::https://github.com/FreeCAD/FreeCAD/compare/$pkgver...$_rollup.patch"
"${pkgname}.desktop" "${pkgname}.xml"
- 'remove-qtwebkit.patch' 'gcc8.patch' 'smesh-pthread.patch')
+ 'gcc8.patch' 'smesh-pthread.patch' 'qt5.11.patch')
sha256sums=('ae017393476b6dc7f1192bcaf91ceedc2f9b791f2495307ce7c45efadb5266fb'
'c4a4e084da448c78644e8acc1f3158cf2cb82ee4936b5b79e282497fd62d566e'
'617968d7bbd1da71bdedaed1b66c5d6eaf24e0fb34678b93f5d925d370c66296'
'248918de7d3c2145b5cc4fbbc9e224d22f4a6ca7ead2680e8c3a32e91772482a'
- 'de214a281d421d44b02b469ecf72e36c4d61f10c40431e511e09734aca316baf'
'618bb85c4f3a4eb0e329d1fc30391b777c9b0cffe97aa1e96d45f58b18424311'
- '170c90ee6ef64cf3c8e6a35ca94bb1187d346707f7e0779022e614563c6b74f6')
+ '170c90ee6ef64cf3c8e6a35ca94bb1187d346707f7e0779022e614563c6b74f6'
+ 'a639c9d51f8443e4d2270fe60d5ac3ac62c7c64c532620108514840f8e8704bc')
prepare() {
cd "${srcdir}/FreeCAD-${pkgver}"
patch -Np1 -i ../$pkgname-$_rollup-rollup.patch
- patch -Np1 -i ../remove-qtwebkit.patch
patch -Np1 -i ../gcc8.patch
patch -Np1 -i ../smesh-pthread.patch
+ patch -Np1 -i ../qt5.11.patch
}
build() {
@@ -52,6 +51,8 @@ build() {
-DCMAKE_INSTALL_DATADIR="/usr/share/freecad" \
-DFREECAD_USE_OCC_VARIANT="Official Version" \
-DFREECAD_USE_EXTERNAL_PIVY=ON \
+ -DBUILD_QT5=ON \
+ -DBUILD_QT5_WEBKIT=OFF \
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DBUILD_START=OFF \
-DBUILD_WEB=OFF
diff --git a/qt5.11.patch b/qt5.11.patch
new file mode 100644
index 000000000000..2638ed19ff67
--- /dev/null
+++ b/qt5.11.patch
@@ -0,0 +1,310 @@
+From 018b41032a5af616fb861538695f8be14ad120ce Mon Sep 17 00:00:00 2001
+From: sL1pKn07 <sl1pkn07@gmail.com>
+Date: Sat, 7 Apr 2018 02:17:49 +0200
+Subject: [PATCH] [For v018] Fix build with Qt5 beta
+
+Seems need add some headers for build with incoming Qt 5.11 (Tested with 5.11.0beta2)
+---
+ src/Mod/Fem/Gui/TaskFemConstraintBearing.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintContact.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintDisplacement.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintFixed.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintFluidBoundary.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintForce.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintHeatflux.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintPlaneRotation.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintPressure.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintTemperature.cpp | 1 +
+ src/Mod/Fem/Gui/TaskFemConstraintTransform.cpp | 1 +
+ src/Mod/MeshPart/Gui/Tessellation.cpp | 1 +
+ src/Mod/Part/Gui/DlgSettingsGeneral.cpp | 3 +++
+ src/Mod/PartDesign/Gui/TaskBooleanParameters.cpp | 1 +
+ src/Mod/PartDesign/Gui/TaskChamferParameters.cpp | 1 +
+ src/Mod/PartDesign/Gui/TaskDraftParameters.cpp | 1 +
+ src/Mod/PartDesign/Gui/TaskFilletParameters.cpp | 1 +
+ src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp | 1 +
+ src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp | 1 +
+ src/Mod/PartDesign/Gui/TaskMultiTransformParameters.cpp | 1 +
+ src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp | 1 +
+ src/Mod/PartDesign/Gui/TaskScaledParameters.cpp | 1 +
+ src/Mod/PartDesign/Gui/TaskThicknessParameters.cpp | 1 +
+ 23 files changed, 25 insertions(+)
+
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintBearing.cpp b/src/Mod/Fem/Gui/TaskFemConstraintBearing.cpp
+index c3992f9d8aa..cd9b64a9463 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintBearing.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintBearing.cpp
+@@ -28,6 +28,7 @@
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <QMessageBox>
++# include <QAction>
+ # include <Precision.hxx>
+ # include <TopoDS.hxx>
+ # include <BRepAdaptor_Surface.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintContact.cpp b/src/Mod/Fem/Gui/TaskFemConstraintContact.cpp
+index c445ca1c8b7..6fe9898e136 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintContact.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintContact.cpp
+@@ -32,6 +32,7 @@
+ # include <Geom_Plane.hxx>
+ # include <Precision.hxx>
+ # include <QMessageBox>
++# include <QAction>
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <TopoDS.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintDisplacement.cpp b/src/Mod/Fem/Gui/TaskFemConstraintDisplacement.cpp
+index 0a83e737b50..cfb16d9d81b 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintDisplacement.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintDisplacement.cpp
+@@ -32,6 +32,7 @@
+ # include <Geom_Plane.hxx>
+ # include <Precision.hxx>
+ # include <QMessageBox>
++# include <QAction>
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <TopoDS.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintFixed.cpp b/src/Mod/Fem/Gui/TaskFemConstraintFixed.cpp
+index 0d864e47ec9..183719432e0 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintFixed.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintFixed.cpp
+@@ -29,6 +29,7 @@
+ # include <Geom_Plane.hxx>
+ # include <Precision.hxx>
+ # include <QMessageBox>
++# include <QAction>
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <TopoDS.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintFluidBoundary.cpp b/src/Mod/Fem/Gui/TaskFemConstraintFluidBoundary.cpp
+index c9964403b4a..8aaacdcf4e1 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintFluidBoundary.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintFluidBoundary.cpp
+@@ -29,6 +29,7 @@
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <QMessageBox>
++# include <QAction>
+ # include <Precision.hxx>
+ # include <TopoDS.hxx>
+ # include <TopoDS_Shape.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintForce.cpp b/src/Mod/Fem/Gui/TaskFemConstraintForce.cpp
+index 33deb1b005b..94fa4209aa2 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintForce.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintForce.cpp
+@@ -28,6 +28,7 @@
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <QMessageBox>
++# include <QAction>
+ # include <Precision.hxx>
+ # include <TopoDS.hxx>
+ # include <BRepAdaptor_Surface.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintHeatflux.cpp b/src/Mod/Fem/Gui/TaskFemConstraintHeatflux.cpp
+index 344b8d32ba1..20a636215de 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintHeatflux.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintHeatflux.cpp
+@@ -32,6 +32,7 @@
+ # include <Geom_Plane.hxx>
+ # include <Precision.hxx>
+ # include <QMessageBox>
++# include <QAction>
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <TopoDS.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintPlaneRotation.cpp b/src/Mod/Fem/Gui/TaskFemConstraintPlaneRotation.cpp
+index b4c3cb03bb3..29d90c3341b 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintPlaneRotation.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintPlaneRotation.cpp
+@@ -30,6 +30,7 @@
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <QMessageBox>
++# include <QAction>
+ # include <Precision.hxx>
+ # include <TopoDS.hxx>
+ # include <BRepAdaptor_Surface.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintPressure.cpp b/src/Mod/Fem/Gui/TaskFemConstraintPressure.cpp
+index 2da2b11cb6b..a85289183f6 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintPressure.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintPressure.cpp
+@@ -30,6 +30,7 @@
+ # include <Geom_Plane.hxx>
+ # include <Precision.hxx>
+ # include <QMessageBox>
++# include <QAction>
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <TopoDS.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintTemperature.cpp b/src/Mod/Fem/Gui/TaskFemConstraintTemperature.cpp
+index 42c0d8f2eb2..88e9029fd5f 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintTemperature.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintTemperature.cpp
+@@ -32,6 +32,7 @@
+ # include <Geom_Plane.hxx>
+ # include <Precision.hxx>
+ # include <QMessageBox>
++# include <QAction>
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <TopoDS.hxx>
+diff --git a/src/Mod/Fem/Gui/TaskFemConstraintTransform.cpp b/src/Mod/Fem/Gui/TaskFemConstraintTransform.cpp
+index 35a1fcf5bf6..e3afeb785c9 100644
+--- a/src/Mod/Fem/Gui/TaskFemConstraintTransform.cpp
++++ b/src/Mod/Fem/Gui/TaskFemConstraintTransform.cpp
+@@ -33,6 +33,7 @@
+ # include <Geom_Plane.hxx>
+ # include <Precision.hxx>
+ # include <QMessageBox>
++# include <QAction>
+ # include <QRegExp>
+ # include <QTextStream>
+ # include <TopoDS.hxx>
+diff --git a/src/Mod/MeshPart/Gui/Tessellation.cpp b/src/Mod/MeshPart/Gui/Tessellation.cpp
+index e392d470b7e..7636ad2fbbc 100644
+--- a/src/Mod/MeshPart/Gui/Tessellation.cpp
++++ b/src/Mod/MeshPart/Gui/Tessellation.cpp
+@@ -25,6 +25,7 @@
+ #ifndef _PreComp_
+ # include <TopExp_Explorer.hxx>
+ # include <QMessageBox>
++# include <QButtonGroup>
+ #endif
+
+ #include "Tessellation.h"
+diff --git a/src/Mod/Part/Gui/DlgSettingsGeneral.cpp b/src/Mod/Part/Gui/DlgSettingsGeneral.cpp
+index d0cf0f94eee..b44eac6ff70 100644
+--- a/src/Mod/Part/Gui/DlgSettingsGeneral.cpp
++++ b/src/Mod/Part/Gui/DlgSettingsGeneral.cpp
+@@ -22,6 +22,9 @@
+
+
+ #include "PreCompiled.h"
++#ifndef _PreComp_
++# include <QButtonGroup>
++#endif
+
+ #include <Interface_Static.hxx>
+
+diff --git a/src/Mod/PartDesign/Gui/TaskBooleanParameters.cpp b/src/Mod/PartDesign/Gui/TaskBooleanParameters.cpp
+index 78570544845..7e3280065ca 100644
+--- a/src/Mod/PartDesign/Gui/TaskBooleanParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskBooleanParameters.cpp
+@@ -25,6 +25,7 @@
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
++# include <QAction>
+ #endif
+
+ #include "ui_TaskBooleanParameters.h"
+diff --git a/src/Mod/PartDesign/Gui/TaskChamferParameters.cpp b/src/Mod/PartDesign/Gui/TaskChamferParameters.cpp
+index 330d5853512..4600cc25b62 100644
+--- a/src/Mod/PartDesign/Gui/TaskChamferParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskChamferParameters.cpp
+@@ -24,6 +24,7 @@
+ #include "PreCompiled.h"
+
+ #ifndef _PreComp_
++# include <QAction>
+ #endif
+
+ #include "ui_TaskChamferParameters.h"
+diff --git a/src/Mod/PartDesign/Gui/TaskDraftParameters.cpp b/src/Mod/PartDesign/Gui/TaskDraftParameters.cpp
+index 556fc92ae1f..020148001cd 100644
+--- a/src/Mod/PartDesign/Gui/TaskDraftParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskDraftParameters.cpp
+@@ -25,6 +25,7 @@
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
++# include <QAction>
+ #endif
+
+ #include "ui_TaskDraftParameters.h"
+diff --git a/src/Mod/PartDesign/Gui/TaskFilletParameters.cpp b/src/Mod/PartDesign/Gui/TaskFilletParameters.cpp
+index 3c4025574ad..5e0c31ec64a 100644
+--- a/src/Mod/PartDesign/Gui/TaskFilletParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskFilletParameters.cpp
+@@ -24,6 +24,7 @@
+ #include "PreCompiled.h"
+
+ #ifndef _PreComp_
++# include <QAction>
+ #endif
+
+ #include "ui_TaskFilletParameters.h"
+diff --git a/src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp b/src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp
+index 532936310be..1970db7ef08 100644
+--- a/src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp
+@@ -25,6 +25,7 @@
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
++# include <QAction>
+ # include <QTimer>
+ #endif
+
+diff --git a/src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp b/src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp
+index 084ab353c35..f8e96fd6c52 100644
+--- a/src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp
+@@ -25,6 +25,7 @@
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
++# include <QAction>
+ #endif
+
+ #include <Base/Console.h>
+diff --git a/src/Mod/PartDesign/Gui/TaskMultiTransformParameters.cpp b/src/Mod/PartDesign/Gui/TaskMultiTransformParameters.cpp
+index 1fe452a593e..d5a5317ae80 100644
+--- a/src/Mod/PartDesign/Gui/TaskMultiTransformParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskMultiTransformParameters.cpp
+@@ -25,6 +25,7 @@
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
++# include <QAction>
+ #endif
+
+ #include "ui_TaskMultiTransformParameters.h"
+diff --git a/src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp b/src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp
+index 874273f63e6..79c564d0965 100644
+--- a/src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp
+@@ -25,6 +25,7 @@
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
++# include <QAction>
+ # include <QTimer>
+ #endif
+
+diff --git a/src/Mod/PartDesign/Gui/TaskScaledParameters.cpp b/src/Mod/PartDesign/Gui/TaskScaledParameters.cpp
+index 593664c9bdb..acaacce6ee8 100644
+--- a/src/Mod/PartDesign/Gui/TaskScaledParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskScaledParameters.cpp
+@@ -25,6 +25,7 @@
+
+ #ifndef _PreComp_
+ # include <QMessageBox>
++# include <QAction>
+ #endif
+
+ #include "ui_TaskScaledParameters.h"
+diff --git a/src/Mod/PartDesign/Gui/TaskThicknessParameters.cpp b/src/Mod/PartDesign/Gui/TaskThicknessParameters.cpp
+index b3f17f299d4..5b907304fcc 100644
+--- a/src/Mod/PartDesign/Gui/TaskThicknessParameters.cpp
++++ b/src/Mod/PartDesign/Gui/TaskThicknessParameters.cpp
+@@ -24,6 +24,7 @@
+ #include "PreCompiled.h"
+
+ #ifndef _PreComp_
++# include <QAction>
+ #endif
+
+ #include "ui_TaskThicknessParameters.h"
diff --git a/remove-qtwebkit.patch b/remove-qtwebkit.patch
deleted file mode 100644
index 555c3806132d..000000000000
--- a/remove-qtwebkit.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/src/Gui/DownloadManager.cpp b/src/Gui/DownloadManager.cpp
-index 98b767d34..31defb46d 100644
---- a/src/Gui/DownloadManager.cpp
-+++ b/src/Gui/DownloadManager.cpp
-@@ -33,9 +33,6 @@
- #include <QMetaEnum>
- #include <QSettings>
- #include <QFileIconProvider>
--#if QT_VERSION < 0x050000
--#include <QWebSettings>
--#endif
- #if QT_VERSION >= 0x050000
- #include <QUrlQuery>
- #endif
-@@ -217,12 +214,6 @@ void DownloadManager::updateRow()
- ui->downloadsView->setRowHeight(row, item->minimumSizeHint().height());
-
- bool remove = false;
--#if QT_VERSION < 0x050000
-- QWebSettings *globalSettings = QWebSettings::globalSettings();
-- if (!item->downloading()
-- && globalSettings->testAttribute(QWebSettings::PrivateBrowsingEnabled))
-- remove = true;
--#endif
-
- if (item->downloadedSuccessfully()
- && removePolicy() == DownloadManager::SuccessFullDownload) {