summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--002-add_stdint.patch11
-rw-r--r--PKGBUILD12
3 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e008e7fb564..84cae254afdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fsl-palm
pkgdesc = PALM is a set of GNU Octave/MATLAB scripts to perform Permutation Analysis for Linear Models
- pkgver = alpha116
+ pkgver = alpha119
pkgrel = 1
url = https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/PALM
arch = any
@@ -9,10 +9,11 @@ pkgbase = fsl-palm
optdepends = octave-image: needed for spatial statistics (you will most likely want this)
optdepends = fsl: support for additional image formats, e.g. compressed NIfTI files
optdepends = freesurfer-bin: support to read/write FreeSurfer files directly
- source = https://s3-us-west-2.amazonaws.com/andersonwinkler/palm/palm-alpha116.tar.gz
+ source = https://s3-us-west-2.amazonaws.com/andersonwinkler/palm/palm-alpha119.tar.gz
source = 001-adjust_path_for_systemwide_install.patch
- sha256sums = 83429e3bd670212e05622767ecd48fc0cbf4383d2294d408ce79fb4933d9d576
+ source = 002-add_stdint.patch
+ sha256sums = 2ed5e45e0cf902388e53b4652718a4d9a3545276d5dafc01420a74608be6924b
sha256sums = 5722799901bc23ca1f391418d6e9d20e92ecce89612cd6e0185cffd51d06bff2
+ sha256sums = b327cb047f09c415af817f44a7d324ca9767ad280c9afce7145dafb06bb64a7a
pkgname = fsl-palm
-
diff --git a/002-add_stdint.patch b/002-add_stdint.patch
new file mode 100644
index 000000000000..fdb2c202e6c1
--- /dev/null
+++ b/002-add_stdint.patch
@@ -0,0 +1,11 @@
+--- a/fileio/@gifti/private/miniz.c 2021-06-01 19:58:59.000000000 +0200
++++ b/fileio/@gifti/private/miniz.c 2021-10-15 18:43:05.397466073 +0200
+@@ -177,7 +177,7 @@
+ #endif
+
+ #include <stddef.h>
+-
++#include <stdint.h>
+ #if !defined(MINIZ_NO_TIME) && !defined(MINIZ_NO_ARCHIVE_APIS)
+ #include <time.h>
+ #endif
diff --git a/PKGBUILD b/PKGBUILD
index 746fdbad1f8a..391d55c430be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsl-palm
-pkgver=alpha116
+pkgver=alpha119
pkgrel=1
pkgdesc="PALM is a set of GNU Octave/MATLAB scripts to perform Permutation Analysis for Linear Models"
arch=('any')
@@ -11,13 +11,16 @@ optdepends=('octave-image: needed for spatial statistics (you will most likely w
'fsl: support for additional image formats, e.g. compressed NIfTI files'
'freesurfer-bin: support to read/write FreeSurfer files directly')
source=("https://s3-us-west-2.amazonaws.com/andersonwinkler/palm/${pkgname##fsl-}-${pkgver}.tar.gz"
- "001-adjust_path_for_systemwide_install.patch")
-sha256sums=('83429e3bd670212e05622767ecd48fc0cbf4383d2294d408ce79fb4933d9d576'
- '5722799901bc23ca1f391418d6e9d20e92ecce89612cd6e0185cffd51d06bff2')
+ "001-adjust_path_for_systemwide_install.patch"
+ "002-add_stdint.patch")
+sha256sums=('2ed5e45e0cf902388e53b4652718a4d9a3545276d5dafc01420a74608be6924b'
+ '5722799901bc23ca1f391418d6e9d20e92ecce89612cd6e0185cffd51d06bff2'
+ 'b327cb047f09c415af817f44a7d324ca9767ad280c9afce7145dafb06bb64a7a')
prepare() {
cd "${srcdir}"/${pkgname##fsl-}-${pkgver}
patch -Np1 -i "${srcdir}"/001-adjust_path_for_systemwide_install.patch
+ patch -Np1 -i "${srcdir}"/002-add_stdint.patch
}
build() {
@@ -25,7 +28,6 @@ build() {
cd "${srcdir}"
for sourcefile in $(find . -type f -name '*.c'); do
outfile=${sourcefile//.c/.mex}
- rm "${outfile}" # Unneccessary, just for clarity purposes
/usr/bin/mkoctfile -v --mex "${sourcefile}" -o "${outfile}"
done
}