summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
-rw-r--r--fsniper.install26
-rw-r--r--fsniper.service9
4 files changed, 64 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86434ea4b986..a6a1a3435244 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
-# Generated by mksrcinfo v8
-# Tue Sep 27 14:38:45 UTC 2016
pkgbase = fsniper
pkgdesc = Daemon to run scripts based on changes in files monitored by inotify
pkgver = 1.3.1
- pkgrel = 3
+ pkgrel = 4
url = http://projects.l3ib.org/fsniper/
+ install = fsniper.install
arch = i686
arch = x86_64
license = GPL3
@@ -14,10 +13,13 @@ pkgbase = fsniper
makedepends = gcc
depends = pcre
depends = file
- source = http://projects.l3ib.org/fsniper/files/fsniper-1.3.1.tar.gz
+ provides = fsniper
+ conflicts = fsniper-git
+ source = http://web.archive.org/web/20180624104931/http://projects.l3ib.org/fsniper/files/fsniper-1.3.1.tar.gz
source = wait3_argument.patch
+ source = fsniper.service
sha256sums = e65a34221fc05eb7ececcd2fb783e3418de032f89082e09be3a8f75f6b056e6b
sha256sums = 60e8390538728b463845c595cb035529fbaaa311a54b6a12eaee2c53688de55d
+ sha256sums = ad278b76022482be1fd2d6836fde450142ff76505b8fd81ab924fc92dba07345
pkgname = fsniper
-
diff --git a/PKGBUILD b/PKGBUILD
index dc21d48f6553..3f3ec00f28ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
-# Maintainer: Javier Tiá <javier dot tia at gmail dot com>
+# Maintainer: Jose Riha <jose 1711 gmail com>
+# Contributor: Javier Tiá <javier dot tia at gmail dot com>
# Contributor: András Wacha <wacha dot andras at ttk dot mta dot hu>
pkgname=fsniper
pkgver=1.3.1
-pkgrel=3
+pkgrel=4
pkgdesc='Daemon to run scripts based on changes in files monitored by inotify'
url='http://projects.l3ib.org/fsniper/'
license=('GPL3')
depends=('pcre' 'file')
makedepends=('autoconf' 'automake' 'libtool' 'gcc')
-source=("http://projects.l3ib.org/fsniper/files/${pkgname}-${pkgver}.tar.gz"
- "wait3_argument.patch")
+provides=(fsniper)
+conflicts=(fsniper-git)
+install=fsniper.install
+source=("http://web.archive.org/web/20180624104931/http://projects.l3ib.org/fsniper/files/${pkgname}-${pkgver}.tar.gz"
+ "wait3_argument.patch"
+ "fsniper.service")
sha256sums=('e65a34221fc05eb7ececcd2fb783e3418de032f89082e09be3a8f75f6b056e6b'
- '60e8390538728b463845c595cb035529fbaaa311a54b6a12eaee2c53688de55d')
+ '60e8390538728b463845c595cb035529fbaaa311a54b6a12eaee2c53688de55d'
+ 'ad278b76022482be1fd2d6836fde450142ff76505b8fd81ab924fc92dba07345')
arch=('i686' 'x86_64')
prepare() {
@@ -22,20 +28,23 @@ prepare() {
build() {
cd ${srcdir}/${pkgname}-${pkgver}
-
+ aclocal
+ autoconf
+ autoheader
+ automake --add-missing
./configure --prefix=/usr
- make || return 1
+ make
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
-
make DESTDIR=${pkgdir} install
-
- install -m644 -D ${srcdir}/${pkgname}-${pkgver}/README \
- ${pkgdir}/usr/share/${pkgname}/README
- install -m644 -D ${srcdir}/${pkgname}-${pkgver}/example.conf \
- ${pkgdir}/usr/share/${pkgname}/example.conf
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/README \
+ ${pkgdir}/usr/share/doc/${pkgname}/README
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/example.conf \
+ ${pkgdir}/usr/share/doc/${pkgname}/example.conf
+ install -Dm644 ${srcdir}/fsniper.service ${pkgdir}/usr/lib/systemd/user/fsniper.service
+ install -Dm644 doc/* ${pkgdir}/usr/share/doc/${pkgname}
}
# vim:set ts=2 sw=2 ft=sh et:
diff --git a/fsniper.install b/fsniper.install
new file mode 100644
index 000000000000..69a607d2ead0
--- /dev/null
+++ b/fsniper.install
@@ -0,0 +1,26 @@
+post_install() {
+ cat <<HERE
+Start by copying the sample config file and modify it to your taste:
+
+mkdir ~/.config/fsniper
+cp /usr/share/doc/fsniper-git/example.conf ~/.config/fsniper/config
+
+Make sure to use /usr/share/doc/fsniper-git/doc.txt as a reference.
+
+If you want fsniper to start on login and X11/Wayland session is required:
+systemctl --user add-wants graphical-session.target fsniper.service
+
+If you still want it to start automatically but it only requires console:
+systemctl --user enable fsniper.service
+HERE
+}
+
+post_remove() {
+ cat <<HERE
+Consider running
+
+systemctl --user disable fsniper
+
+for all users.
+HERE
+}
diff --git a/fsniper.service b/fsniper.service
new file mode 100644
index 000000000000..c086dd9bed89
--- /dev/null
+++ b/fsniper.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=fsniper service
+
+[Service]
+ExecStart=/usr/bin/fsniper
+Restart=always
+
+[Install]
+WantedBy=default.target