summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD19
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5ada327c40a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fsplayer
+ pkgdesc = FS.TO video player built in Python & GTK3.
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://github.com/and3rson/fsplayer
+ arch = any
+ license = GPL2
+ depends = python2
+ depends = gtk3
+ depends = python2-beautifulsoup4
+ depends = python2-selenium
+ depends = gobject-introspection-runtime
+ options = !strip
+ source = git+https://github.com/and3rson/fsplayer.git
+ md5sums = SKIP
+
+pkgname = fsplayer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3c329394fda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=fsplayer
+pkgver=0.3
+pkgrel=1
+pkgdesc="FS.TO video player built in Python & GTK3."
+arch=('any')
+url="http://github.com/and3rson/fsplayer"
+license=('GPL2')
+depends=('python2' 'gtk3' 'python2-beautifulsoup4' 'python2-selenium' 'gobject-introspection-runtime')
+options=('!strip')
+source=('git+https://github.com/and3rson/fsplayer.git')
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/lib
+ cp -r ${srcdir}/${pkgname} ${pkgdir}/usr/lib/${pkgname}
+ ln -s /usr/lib/${pkgname}/main.py ${pkgdir}/usr/bin/${pkgname}
+}
+
+md5sums=('SKIP')