summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef20e76f2565..33051113625d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,13 +8,23 @@ pkgbase = furious-git
makedepends = git
makedepends = cmake
makedepends = python
- makedepends = python-pip
makedepends = patchelf
makedepends = go1.20
+ makedepends = python-wheel
+ makedepends = pyside6
+ makedepends = xray
+ makedepends = hysteria
+ makedepends = hysteria1
+ makedepends = tun2socks
+ makedepends = python-ujson
+ makedepends = python-pyqrcode
+ makedepends = python-pypng
+ makedepends = python-ping3
+ makedepends = nuitka
+ makedepends = pybase64
optdepends = gnome-shell-extension-appindicator: for system tray icon if you are using Gnome
provides = furious
conflicts = furious
- options = !strip
source = git+https://github.com/LorenEteval/Furious.git
source = furious.png
source = furious.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 183db750c24d..d38e91cc298c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,12 @@ pkgdesc="A PySide6-based cross platform GUI client that launches your beloved GF
arch=(x86_64)
url='https://github.com/LorenEteval/Furious'
license=('GPL3')
-makedepends=('git' 'cmake' 'python' 'python-pip' 'patchelf' 'go1.20')
+makedepends=('git' 'cmake' 'python' 'patchelf' 'go1.20' 'python-wheel' 'pyside6' 'xray' 'hysteria' 'hysteria1' 'tun2socks' 'python-ujson' 'python-pyqrcode' 'python-pypng' 'python-ping3' 'nuitka' 'pybase64')
optdepends=(
'gnome-shell-extension-appindicator: for system tray icon if you are using Gnome'
)
provides=(${_pkgname})
conflicts=(${_pkgname})
-options=(!strip)
source=(
"git+https://github.com/LorenEteval/Furious.git"
"furious.png"
@@ -35,15 +34,6 @@ pkgver() {
prepare() {
ln -s /usr/bin/go1.20 go
export PATH=$(pwd):$PATH
- cd "${srcdir}"
- python -m venv .venv
- source .venv/bin/activate
- cd "${srcdir}/Furious"
- pip install --upgrade pip
- pip install wheel
- pip install hysteria2==2.0.0.1
- pip install -r requirements.txt
- pip install nuitka
}
build() {
@@ -55,7 +45,7 @@ package() {
cd "${srcdir}/Furious/guiBinaries/__main__.dist/"
find . -type f -exec install -Dm 755 {} "$pkgdir/$_install_path"/{} \;
install -Dm644 "${srcdir}/${_pkgname}.desktop" "$pkgdir/usr/share/applications/${_pkgname}.desktop"
- install -Dm644 "${srcdir}/furious.png" "${pkgdir}/usr/share/icons/hicolor/400x400/apps/furious.png"
+ install -Dm644 "${srcdir}/${_pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/400x400/apps/${_pkgname}.png"
install -dm755 "${pkgdir}/usr/bin"
ln -s "${_install_path}/__main__.bin" "${pkgdir}/usr/bin/${_pkgname}"
} \ No newline at end of file