summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77b658bbc61d..f46630729b90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = furtherance-git
pkgdesc = Track your time without being tracked
- pkgver = 1.0.8.r8.g1ff89ff
+ pkgver = 1.5.4.r1.gf953f8f
pkgrel = 1
- url = https://github.com/lakoliu/Furtherance
+ url = https://github.com/lakoliu/furtherance
arch = x86_64
license = GPL3
makedepends = git
@@ -13,7 +13,7 @@ pkgbase = furtherance-git
depends = sqlite
provides = furtherance
conflicts = furtherance
- source = git+https://github.com/lakoliu/Furtherance.git
+ source = git+https://github.com/lakoliu/furtherance.git
b2sums = SKIP
pkgname = furtherance-git
diff --git a/PKGBUILD b/PKGBUILD
index 65664e00b790..e5a27bf68145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: musiclover <musiclover382@protonmail.com>
pkgname=furtherance-git
-pkgver=1.0.8.r8.g1ff89ff
+pkgver=1.5.4.r1.gf953f8f
pkgrel=1
pkgdesc='Track your time without being tracked'
arch=(x86_64)
-url=https://github.com/lakoliu/Furtherance
+url=https://github.com/lakoliu/${pkgname%-git}
license=(GPL3)
depends=('gtk4' 'libadwaita' 'sqlite')
makedepends=('git' 'meson' 'rust')
@@ -15,12 +15,17 @@ source=(git+$url.git)
b2sums=('SKIP')
pkgver() {
- cd Furtherance
+ cd ${pkgname%-git}
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd ${pkgname%-git}
+ cargo update
+}
+
build() {
- arch-meson Furtherance build
+ arch-meson ${pkgname%-git} build
meson compile -C build
}