summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--wrapper.sh4
3 files changed, 11 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c53023d0d177..e126c33a812a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = fusee-nano-git
- pkgdesc = A minimalist re-implementation of the Fusée Gelée exploit, designed to run on embedded Linux devices.
- pkgver = 0.4.0.gdde2492
+ pkgdesc = A minimalist re-implementation of the Fusée Gelée exploit (git version)
+ pkgver = 0.5.3.2.ge3642e0
pkgrel = 1
url = https://github.com/DavidBuchanan314/fusee-nano
arch = any
license = mit
makedepends = git
+ makedepends = vim
source = fusee-nano::git+https://github.com/DavidBuchanan314/fusee-nano
- source = wrapper.sh
- md5sums = SKIP
md5sums = SKIP
pkgname = fusee-nano-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 38040ae2ff12..916fd2efff9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
-# Maintainer: Ave Ozkal <aurpub@ave.zone>
+# Maintainer: David Buchanan <d@vidbuchanan.co.uk>
+# Contributor: Ave Ozkal <aurpub@ave.zone>
# Contributor: Nikos Fytilis <n-fit@live.com>
_name=fusee-nano
pkgname="$_name-git"
-pkgver=0.4.0.gdde2492
+pkgver=0.5.3.2.ge3642e0
pkgrel=1
-pkgdesc="A minimalist re-implementation of the Fusée Gelée exploit, designed to run on embedded Linux devices. "
+pkgdesc="A minimalist re-implementation of the Fusée Gelée exploit (git version)"
arch=('any')
url="https://github.com/DavidBuchanan314/fusee-nano"
license=('mit')
-makedepends=('git')
-source=("$_name::git+https://github.com/DavidBuchanan314/fusee-nano"
-'wrapper.sh')
-md5sums=(SKIP
-SKIP)
+makedepends=('git' 'vim')
+source=("$_name::git+https://github.com/DavidBuchanan314/fusee-nano")
+md5sums=(SKIP)
pkgver() {
cd $_name
@@ -27,10 +26,6 @@ build() {
package() {
cd $_name
- mkdir -p $pkgdir/usr/share/$_name/{bin,share}
- mkdir -p $pkgdir/usr/bin
- cp -r files "$pkgdir/usr/share/$_name/share"
- install -m 755 fusee-nano "${pkgdir}/usr/share/$_name/bin/fusee-nano"
- install -m 755 $srcdir/wrapper.sh "${pkgdir}/usr/bin/fusee-nano"
+ make install "PREFIX=${pkgdir}/usr/bin"
}
diff --git a/wrapper.sh b/wrapper.sh
deleted file mode 100644
index 2d1daa3d3f68..000000000000
--- a/wrapper.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/usr/bin/sh
-
-cd /usr/share/fusee-nano/share
-../bin/fusee-nano $*