summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a45e3d093b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fuzzy-pdf-bin
+ pkgdesc = Fuzzy finder for a collection of pdf files
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://github.com/MarioJim/fuzzy-pdf
+ arch = x86_64
+ license = GPL3
+ depends = poppler-glib
+ provides = fuzzy-pdf
+ conflicts = fuzzy-pdf
+ source = fuzzy-pdf::https://github.com/MarioJim/fuzzy-pdf/releases/download/v0.3.6/fuzzy-pdf
+ sha256sums = ebb0b219eda3e9b2b2305149823f08cd220f58f3d65fe9d1ad79fd8c014051dd
+
+pkgname = fuzzy-pdf-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a60b7d2c8bce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Mario Jiménez <mario.emilio.j@gmail.com>
+
+pkgname=fuzzy-pdf-bin
+_pkgname=fuzzy-pdf
+pkgver=0.3.6
+pkgrel=1
+pkgdesc='Fuzzy finder for a collection of pdf files'
+arch=('x86_64')
+url='https://github.com/MarioJim/fuzzy-pdf'
+license=('GPL3')
+depends=('poppler-glib')
+provides=('fuzzy-pdf')
+conflicts=('fuzzy-pdf')
+source=("${_pkgname}::${url}/releases/download/v${pkgver}/fuzzy-pdf")
+sha256sums=('ebb0b219eda3e9b2b2305149823f08cd220f58f3d65fe9d1ad79fd8c014051dd')
+
+package() {
+ install -Dm 755 "${srcdir}/${_pkgname}" -t "${pkgdir}/usr/bin"
+}