summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69a0b6810bef..721b6b760e06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = g4see-git
makedepends = cmake
depends = geant4
depends = python
- provides = g4see
+ provides = g4see=v0.5.1
conflicts = g4see
source = git+https://gitlab.cern.ch/g4see/g4see.git
source = git+https://gitlab.cern.ch/g4see/g4see-scripts.git
diff --git a/PKGBUILD b/PKGBUILD
index 27e6717e73e8..09c7913dffe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ license=('GPL3')
depends=('geant4' 'python')
makedepends=('cmake')
conflicts=('g4see')
-provides=('g4see')
+provides=("g4see=$pkgver")
source=("git+https://gitlab.cern.ch/g4see/g4see.git"
"git+https://gitlab.cern.ch/g4see/g4see-scripts.git")
sha1sums=('SKIP' 'SKIP')
@@ -41,7 +41,11 @@ package() {
cd "$srcdir/$_gitname/build"
make install
- install -Dm644 -t "$pkgdir"/usr/share/licenses/"$pkgname" ../LICENSES/*
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/"$_gitname" ../LICENSES/*
+ install -Dm644 -t "$pkgdir"/usr/share/"$_gitname"/scripts scripts/*
+ install -Dm644 -t "$pkgdir"/usr/share/"$_gitname"/examples examples/*
+ install -Dm644 -t "$pkgdir"/usr/share/"$_gitname"/examples_parametric examples_parametric/*
+ install -Dm644 -t "$pkgdir"/usr/share/"$_gitname"/configs configs/*
}
# vim:set ts=2 sw=2 et: