summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD54
2 files changed, 57 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3152ea3ffe71..6f8ff39d59e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,40 @@
pkgbase = gammastep-git
- pkgdesc = Adjusts the color temperature of your screen according to your surroundings.
- pkgver = 1.12.r37.ge3ddf54
+ pkgdesc = Adjust the color temperature of your screen according to your surroundings.
+ pkgver = 2.0.7.r1.gc5c3ac0
pkgrel = 1
- url = https://github.com/CameronNemo/redshift
+ url = https://gitlab.com/chinstrap/gammastep
arch = x86_64
license = GPL3
+ makedepends = git
+ makedepends = glib2
makedepends = intltool
makedepends = python
- makedepends = git
- depends = glib2
- depends = wayland
+ makedepends = systemd
+ depends = geoclue
+ depends = glibc
+ depends = hicolor-icon-theme
depends = libdrm
+ depends = libx11
+ depends = libxcb
depends = libxxf86vm
- depends = geoclue
+ depends = wayland
optdepends = python-gobject: for gammastep-indicator
optdepends = python-xdg: for gammastep-indicator
optdepends = gtk3: for gammastep-indicator
- source = git+https://github.com/CameronNemo/redshift
- md5sums = SKIP
+ provides = gammastep
+ conflicts = gammastep
+ source = git+https://gitlab.com/chinstrap/gammastep.git
+ sha256sums = SKIP
pkgname = gammastep-git
-
+ depends = geoclue
+ depends = glibc
+ depends = hicolor-icon-theme
+ depends = libdrm
+ depends = libx11
+ depends = libxcb
+ depends = libxxf86vm
+ depends = wayland
+ depends = libgio-2.0.so
+ depends = libgobject-2.0.so
+ depends = libglib-2.0.so
diff --git a/PKGBUILD b/PKGBUILD
index 5c03970b8f8f..5f729800c225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,49 @@
-# Maintainer: Carlo Teubner <carlo at cteubner dot net>
-# Contributor: Brett Cornwall <ainola@archlinux.org>
-# Contributor: Andrey Solomatin
-# Contributor: carstene1ns
-# Contributor: Lukas Fleischer
-# Contributor: Geoffrey Teale
-# Contributor: Mark, Huo Mian
-# Contributor: Biginoz
-# Contributor: Mattias Andrée
+# Maintainer: Cedric Girard <cgirard [dot] archlinux [at] valinor [dot] fr>
+# Contributor: David Runge <dvzrv@archlinux.org>
pkgname=gammastep-git
-pkgver=1.12.r37.ge3ddf54
+pkgver=2.0.7.r1.gc5c3ac0
pkgrel=1
-pkgdesc="Adjusts the color temperature of your screen according to your surroundings."
+pkgdesc="Adjust the color temperature of your screen according to your surroundings."
arch=('x86_64')
-url="https://github.com/CameronNemo/redshift"
+url="https://gitlab.com/chinstrap/gammastep"
license=('GPL3')
-depends=('glib2' 'wayland' 'libdrm' 'libxxf86vm' 'geoclue')
+provides=('gammastep')
+conflicts=('gammastep')
+depends=('geoclue' 'glibc' 'hicolor-icon-theme' 'libdrm' 'libx11' 'libxcb'
+'libxxf86vm' 'wayland')
+makedepends=('git' 'glib2' 'intltool' 'python' 'systemd')
optdepends=('python-gobject: for gammastep-indicator'
'python-xdg: for gammastep-indicator'
'gtk3: for gammastep-indicator')
-makedepends=('intltool' 'python' 'git')
-source=("git+https://github.com/CameronNemo/redshift")
-md5sums=('SKIP')
+source=("git+https://gitlab.com/chinstrap/gammastep.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/redshift"
- git describe --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ cd gammastep
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd "$srcdir/redshift"
+prepare() {
+ cd "$srcdir"/gammastep
./bootstrap
+}
+
+build() {
+ cd "$srcdir"/gammastep
./configure --prefix=/usr
make
}
-package() {
- cd "$srcdir/redshift"
- make DESTDIR="$pkgdir" install
+check() {
+ cd "$srcdir"/gammastep
+ make -k check
}
-# vim:set ts=2 sw=2 et:
+package() {
+ depends+=('libgio-2.0.so' 'libgobject-2.0.so' 'libglib-2.0.so')
+ cd "$srcdir"/gammastep
+ make DESTDIR="$pkgdir/" install
+ install -vDm 644 {CONTRIBUTING,NEWS,README}.md \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
+}