summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD3
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8910ee8caef..580ca234d2f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gcc6
pkgdesc = The GNU Compiler Collection (6.x.x)
pkgver = 6.5.0
- pkgrel = 8
+ pkgrel = 9
url = https://gcc.gnu.org/gcc-6/
arch = x86_64
license = GPL
@@ -35,7 +35,7 @@ pkgbase = gcc6
pkgname = gcc6
pkgdesc = The GNU Compiler Collection - C and C++ frontends (6.x.x)
- depends = gcc6-libs=6.5.0-8
+ depends = gcc6-libs=6.5.0-9
depends = binutils>=2.28
depends = libmpc
depends = zlib
@@ -49,13 +49,13 @@ pkgname = gcc6-libs
pkgname = gcc6-fortran
pkgdesc = Fortran front-end for GCC
- depends = gcc6=6.5.0-8
+ depends = gcc6=6.5.0-9
depends = zlib
depends = libmpc
pkgname = gcc6-gcj
pkgdesc = Java front-end for GCC
- depends = gcc6=6.5.0-8
+ depends = gcc6=6.5.0-9
depends = libmpc
depends = libxtst
depends = gtk2
diff --git a/PKGBUILD b/PKGBUILD
index e6374d2530ed..4bf637b960c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ pkgver=6.5.0
_ver=${pkgver%%.*}
_islver=0.18
_cloogver=0.18.4
-pkgrel=8
+pkgrel=9
pkgdesc="The GNU Compiler Collection (6.x.x)"
arch=(x86_64)
license=(GPL LGPL FDL custom)
@@ -231,6 +231,7 @@ package_gcc6() {
# Lazy way of dealing with conflicting files...
rm -rf "${pkgdir}"/usr/share/{info,locale,man}
+ rm -rf "${pkgdir}"/"${_libdir}"/libstdc++.{a,la}
# Move potentially conflicting stuff to version specific subdirectory
mv "${pkgdir}"/usr/lib/bfd-plugins/liblto_plugin.so "${pkgdir}"/usr/lib/bfd-plugins/liblto_plugin-${_ver}.so