summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO46
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD84
3 files changed, 73 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 926d7ca15892..dd9a9e955b95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,52 @@
pkgbase = geany-git
pkgdesc = Fast and lightweight IDE (git version)
- pkgver = 1.38.0.r151.gdf27d1b22
+ pkgver = 2.0.0.r118.gef2255bce
pkgrel = 1
- url = https://github.com/geany/geany
+ url = https://www.geany.org/
arch = x86_64
- arch = i686
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = doxygen
makedepends = git
- makedepends = intltool
- makedepends = python-lxml
+ makedepends = gtk-doc
+ makedepends = meson
makedepends = python-docutils
- makedepends = python-reportlab
+ makedepends = python-lxml
makedepends = vte3
+ depends = at-spi2-core
+ depends = cairo
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = hicolor-icon-theme
depends = gtk3
+ depends = pango
depends = python
optdepends = geany-plugins: additional functionality
optdepends = vte3: enbedded terminal support
provides = geany
- provides = geany=1.38.0.r151.gdf27d1b22
conflicts = geany
- conflicts = geany-gtk3
- conflicts = geany-gtk3-git
source = geany::git+https://github.com/geany/geany.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = geany-git
+ depends = at-spi2-core
+ depends = cairo
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = hicolor-icon-theme
+ depends = gtk3
+ depends = pango
+ depends = python
+ depends = libatk-1.0.so
+ depends = libcairo.so
+ depends = libgdk_pixbuf-2.0.so
+ depends = libgio-2.0.so
+ depends = libglib-2.0.so
+ depends = libgmodule-2.0.so
+ depends = libgobject-2.0.so
+ depends = libgtk-3.so
+ depends = libpango-1.0.so
+ depends = libpangocairo-1.0.so
diff --git a/.gitignore b/.gitignore
index 3c5ca03be9cc..ed0e9ea3f11b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
geany/
pkg/
src/
-geany-git-*.pkg.tar.xz
-geany-git-*.pkg.tar.zst
+geany-git-*.pkg.tar.*
geany-git-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 83a4e0c38bf2..2791307e81b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,55 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
# Contributor: ksj <podhorsky.ksj@gmail.com>
+# Contributor: yochananmarqos <mark -dot- wagie -at- proton -dot- me>
-_gitname=geany
-pkgname=${_gitname}-git
-pkgver=1.38.0.r151.gdf27d1b22
+_pkgname=geany
+pkgname=$_pkgname-git
+pkgver=2.0.0.r118.gef2255bce
pkgrel=1
-pkgdesc="Fast and lightweight IDE (git version)"
-arch=('x86_64' 'i686')
-url="https://github.com/${_gitname}/${_gitname}"
-license=('GPL2')
-depends=('gtk3' 'python')
-makedepends=('doxygen' 'git' 'intltool' 'python-lxml' 'python-docutils' 'python-reportlab' 'vte3')
+pkgdesc='Fast and lightweight IDE (git version)'
+arch=(x86_64)
+url='https://www.geany.org/'
+license=(GPL-2.0-or-later)
+depends=(at-spi2-core cairo gcc-libs gdk-pixbuf2 glib2 glibc
+ hicolor-icon-theme gtk3 pango python)
+makedepends=(doxygen git gtk-doc meson python-docutils python-lxml vte3)
optdepends=(
- 'geany-plugins: additional functionality'
- 'vte3: enbedded terminal support'
+ 'geany-plugins: additional functionality'
+ 'vte3: enbedded terminal support'
)
-conflicts=("${_gitname}" "${_gitname}-gtk3" "${_gitname}-gtk3-git")
-provides=("${_gitname}" "${_gitname}=$pkgver")
-source=(${_gitname}::git+https://github.com/${_gitname}/${_gitname}.git)
-md5sums=('SKIP')
-
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/$_pkgname/$_pkgname.git")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
-
- (
- set -o pipefail
- git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
-}
-
-prepare() {
- cd "${srcdir}/${_gitname}"
-
- # Syntax highlighting for PKGBUILD files
- sed -i 's/Sh=/Sh=PKGBUILD;/' data/filetype_extensions.conf
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_gitname}"
-
- export CFLAGS="${CFLAGS} -D_FILE_OFFSET_BITS=64"
- ./autogen.sh \
- --enable-api-docs \
- --enable-html-docs \
- --enable-gtk3 \
- --enable-gtkdoc-header \
- --prefix=/usr
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ test -d $_pkgname-build && extra_opts="--reconfigure"
+ arch-meson $_pkgname $_pkgname-build \
+ -Dhtml-docs=enabled \
+ -Dpdf-docs=disabled \
+ -Dplugins=true \
+ -Dapi-docs=enabled \
+ -Dgtkdoc=true \
+ -Dvte=true \
+ -Dmac-integration=disabled \
+ $extra_opts
+ meson compile -C $_pkgname-build
}
check() {
- cd "${srcdir}/${_gitname}"
-
- make check
+ export NO_AT_BRIDGE=1
+ meson test -C $_pkgname-build --print-errorlogs
}
package() {
- cd "${srcdir}/${_gitname}"
-
- make PREFIX=/usr DESTDIR="$pkgdir" install
+ depends+=(libatk-1.0.so libcairo.so libgdk_pixbuf-2.0.so libgio-2.0.so
+ libglib-2.0.so libgmodule-2.0.so libgobject-2.0.so libgtk-3.so
+ libpango-1.0.so libpangocairo-1.0.so)
+ meson install -C $_pkgname-build --destdir "$pkgdir"
+ mv "$pkgdir"/usr/share/doc/$_pkgname "$pkgdir"/usr/share/doc/$pkgname
}