summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
-rw-r--r--desktop-file.patch17
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a968c5adbbdc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = genchemlab
+ pkgdesc = An application intended to simulate common general chemistry laboratory exercises
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/ids1024/genchemlab/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = glu
+ source = https://github.com/ids1024/genchemlab/archive/v1.0.1.tar.gz
+ source = desktop-file.patch
+ md5sums = c67acd494495572c876e807089429dc6
+ md5sums = ca2976a9c05e63682293b8137d5f6048
+
+pkgname = genchemlab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16b2f828df62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ian D. Scott <ian@perebruin.com>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Tutku Dalmaz <tutkudalmaz@gmail.com>>
+
+pkgname=genchemlab
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="An application intended to simulate common general chemistry laboratory exercises"
+arch=('i686' 'x86_64')
+#url="http://genchemlab.sourceforge.net/"
+url="https://github.com/ids1024/genchemlab/"
+license=('GPL')
+depends=('qt5-base' 'glu')
+source=("https://github.com/ids1024/genchemlab/archive/v${pkgver}.tar.gz"
+ "desktop-file.patch")
+md5sums=('c67acd494495572c876e807089429dc6'
+ 'ca2976a9c05e63682293b8137d5f6048')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 -i ../desktop-file.patch
+ qmake-qt5
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make INSTALL_ROOT="${pkgdir}" install
+}
diff --git a/desktop-file.patch b/desktop-file.patch
new file mode 100644
index 000000000000..793a89f9af4d
--- /dev/null
+++ b/desktop-file.patch
@@ -0,0 +1,17 @@
+--- genchemlab-1.0.orig/program/genchemlab.desktop 2003-05-19 21:56:15.000000000 +0600
++++ genchemlab-1.0/program/genchemlab.desktop 2012-05-10 15:53:26.640755878 +0600
+@@ -1,11 +1,9 @@
+ [Desktop Entry]
+ Type=Application
+ Exec=genchemlab
+-Icon=genchemlab.png
+-DocPath=
++Icon=genchemlab
+ Comment=Simulation of a chemical lab.
+ Comment[da]=Et simuleret kemisk laboratorium.
+-Terminal=0
++Terminal=false
+ Name=GenChemLab
+-Encoding=UTF-8
+-Categories=Application;Education;Chemestry;
++Categories=Qt;Education;Science;Chemistry;