summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df23f79fdba5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = geocode-glib-git
+ pkgdesc = Helper library for geocoding services
+ pkgver = 3.26.2+13+ge5905e1
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/geocode-glib
+ arch = x86_64
+ license = LGPL
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = gtk-doc
+ makedepends = meson
+ depends = glib2
+ depends = json-glib
+ depends = libsoup3
+ provides = libgeocode-glib.so
+ provides = geocode-glib
+ conflicts = geocode-glib
+ options = debug
+ source = git+https://gitlab.gnome.org/GNOME/geocode-glib.git
+ sha256sums = SKIP
+
+pkgname = geocode-glib-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b6f2dbc4722
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Veli Tasalı (tasali) <me@velitasali.com>
+
+pkgname=geocode-glib-git
+_pkgname=geocode-glib
+pkgver=3.26.2+13+ge5905e1
+pkgrel=1
+pkgdesc="Helper library for geocoding services"
+url="https://gitlab.gnome.org/GNOME/geocode-glib"
+arch=(x86_64)
+license=(LGPL)
+depends=(glib2 json-glib libsoup3)
+makedepends=(gobject-introspection git gtk-doc meson)
+provides=(libgeocode-glib.so geocode-glib)
+conflicts=(geocode-glib)
+options=(debug)
+source=("git+https://gitlab.gnome.org/GNOME/geocode-glib.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+}
+
+build() {
+ arch-meson $_pkgname build -D enable-installed-tests=false -D soup2=false
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}