summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--CMakeOptions.txt3
-rw-r--r--PKGBUILD43
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0d3a3ef8e8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = geogram-git
+ pkgdesc = a programming library with geometric algorithms
+ pkgver = r117.eb6a4483
+ pkgrel = 1
+ url = https://github.com/BrunoLevy/geogram
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = glfw-x11
+ provides = geogram-git
+ provides = geogram
+ conflicts = geogram-git
+ conflicts = geogram
+ source = git+https://github.com/BrunoLevy/geogram.git
+ source = CMakeOptions.txt
+ md5sums = SKIP
+ md5sums = b6d8637ef7b6fdcdf490b4def8b350f9
+
+pkgname = geogram-git
diff --git a/CMakeOptions.txt b/CMakeOptions.txt
new file mode 100644
index 000000000000..36bfa141a724
--- /dev/null
+++ b/CMakeOptions.txt
@@ -0,0 +1,3 @@
+set(CMAKE_INSTALL_PREFIX /usr)
+set(GEOGRAM_USE_SYSTEM_GLFW3 ON)
+set(GEOGRAM_LIB_ONLY OFF)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ee1543f59cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: subhuman22 <ktmz2@protonmail.com>
+pkgname=geogram-git
+pkgver=r117.eb6a4483
+pkgrel=1
+pkgdesc="a programming library with geometric algorithms"
+arch=(x86_64)
+url="https://github.com/BrunoLevy/geogram"
+license=('BSD')
+groups=()
+depends=('glfw-x11')
+makedepends=('git')
+provides=("$pkgname" "${pkgname%-git}")
+conflicts=("$pkgname" "${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/BrunoLevy/geogram.git' 'CMakeOptions.txt')
+noextract=()
+md5sums=('SKIP' 'b6d8637ef7b6fdcdf490b4def8b350f9')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cp CMakeOptions.txt "$srcdir/${pkgname%-git}"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./configure.sh
+ cd "build/Linux64-gcc-dynamic-Release"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ cd "build/Linux64-gcc-dynamic-Release"
+ make DESTDIR="$pkgdir/" install
+ rm $pkgdir/usr/bin/geogram_demo*
+}