summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f6b37de5e0d..aab5701aa544 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = geph4
pkgdesc = A command-line Geph4 toolset
pkgver = 4.4.7
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/geph-official/geph4
arch = x86_64
groups = geph4
license = GPL3
makedepends = rust
depends = gcc-libs
- source = geph4-4.4.7.tar.gz::https://github.com/geph-official/geph4/archive/v4.4.7.tar.gz
+ source = -4.4.7.tar.gz::https://github.com/geph-official/geph4/archive/v4.4.7.tar.gz
source = geph4-binder.default
source = geph4-bridge.default
source = geph4-client.default
@@ -29,23 +29,4 @@ pkgbase = geph4
sha256sums = 04b096c9e99f655c7f7e9e13082be2a487e255c2366471ad9c9e3216be389774
sha256sums = ae990333a1eebd5d5bb57ebd4a930db84d08a2c7db541d349de119280473e043
-pkgname = geph4-binder
- conflicts = geph4-binder-git
- backup = etc/default/geph4-binder
-
-pkgname = geph4-bridge
- conflicts = geph4-bridge-git
- backup = etc/default/geph4-bridge
-
-pkgname = geph4-client
- conflicts = geph4-client-git
- backup = etc/default/geph4-client
-
-pkgname = geph4-exit
- conflicts = geph4-exit-git
- backup = etc/default/geph4-exit
-
-pkgname = geph4-vpn-helper
- depends = gcc-libs
- depends = geph4-client
- conflicts = geph4-vpn-helper-git
+pkgname = geph4
diff --git a/PKGBUILD b/PKGBUILD
index 9ba6d11083bf..32250346697a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,8 @@
# Maintainer: Dct Mei <dctxmei@yandex.com>
-pkgbase=geph4
-pkgname=('geph4-binder'
- 'geph4-bridge'
- 'geph4-client'
- 'geph4-exit'
- 'geph4-vpn-helper')
+pkgname=geph4
pkgver=4.4.7
-pkgrel=3
+pkgrel=4
pkgdesc="A command-line Geph4 toolset"
arch=('x86_64')
url="https://github.com/geph-official/geph4"
@@ -45,7 +40,7 @@ build() {
cargo build --release --manifest-path=geph4-vpn-helper/Cargo.toml
}
-package_geph4-binder() {
+_package_geph4-binder() {
conflicts=('geph4-binder-git')
backup=('etc/default/geph4-binder')
cd "${srcdir}"/"${pkgbase}-${pkgver}"/
@@ -55,7 +50,7 @@ package_geph4-binder() {
install -Dm 644 "${srcdir}"/geph4-binder.service -t "${pkgdir}"/usr/lib/systemd/system/
}
-package_geph4-bridge() {
+_package_geph4-bridge() {
conflicts=('geph4-bridge-git')
backup=('etc/default/geph4-bridge')
cd "${srcdir}"/"${pkgbase}-${pkgver}"/
@@ -65,7 +60,7 @@ package_geph4-bridge() {
install -Dm 644 "${srcdir}"/geph4-bridge.service -t "${pkgdir}"/usr/lib/systemd/system/
}
-package_geph4-client() {
+_package_geph4-client() {
conflicts=('geph4-client-git')
backup=('etc/default/geph4-client')
cd "${srcdir}"/"${pkgbase}-${pkgver}"/
@@ -75,7 +70,7 @@ package_geph4-client() {
install -Dm 644 "${srcdir}"/geph4-client.service -t "${pkgdir}"/usr/lib/systemd/system/
}
-package_geph4-exit() {
+_package_geph4-exit() {
conflicts=('geph4-exit-git')
backup=('etc/default/geph4-exit')
cd "${srcdir}"/"${pkgbase}-${pkgver}"/
@@ -85,7 +80,7 @@ package_geph4-exit() {
install -Dm 644 "${srcdir}"/geph4-exit.service -t "${pkgdir}"/usr/lib/systemd/system/
}
-package_geph4-vpn-helper() {
+_package_geph4-vpn-helper() {
depends+=('geph4-client')
conflicts=('geph4-vpn-helper-git')
cd "${srcdir}"/"${pkgbase}-${pkgver}"/
@@ -93,3 +88,7 @@ package_geph4-vpn-helper() {
install -Dm 755 target/release/geph4-vpn-helper -t "${pkgdir}"/usr/bin/
install -Dm 644 "${srcdir}"/geph4-vpn-helper.service -t "${pkgdir}"/usr/lib/systemd/system/
}
+
+package() {
+ ls
+}