summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD64
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03259cdc3a12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Wed Oct 26 17:34:51 UTC 2016
+pkgbase = ges-git
+ pkgdesc = (WIP!) Multiplayer Only FPS. A recreation of GoldenEye64 as a Half-Life 2 mod using Source Engine SDK 2013.
+ pkgver = r149.c6bd265
+ pkgrel = 1
+ url = https://www.geshl2.com/
+ arch = i686
+ license = GPLv3
+ makedepends = cmake
+ makedepends = boost-libs
+ makedepends = boost
+ makedepends = git
+ makedepends = gcc
+ makedepends = glibc
+ makedepends = libstdc++5
+ provides = ges-git
+ conflicts = ges
+ source = ges-git::git+https://github.com/goldeneye-source/ges-code.git
+ source = python::git+https://github.com/python-cmake-buildsystem/python-cmake-buildsystem.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ges-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2e823173936d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.gz
+*.xz
+pkg
+src
+.SRCINFO
+ges-git
+python
+PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..134e80b89961
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Electric Prism <electricprism@gmail.com>
+# Contributor: Electric Prism <electricprism@gmail.com>
+# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
+
+pkgname=ges-git
+pkgver=r149.c6bd265
+pkgrel=1
+pkgdesc=" (WIP!) Multiplayer Only FPS. A recreation of GoldenEye64 as a Half-Life 2 mod using Source Engine SDK 2013."
+arch=('i686')
+url="https://www.geshl2.com/"
+license=('GPLv3')
+makedepends=('cmake' 'boost-libs' 'boost' 'git' 'gcc' 'glibc' 'libstdc++5')
+source=('ges-git::git+https://github.com/goldeneye-source/ges-code.git'
+ 'python::git+https://github.com/python-cmake-buildsystem/python-cmake-buildsystem.git')
+sha256sums=('SKIP'
+ 'SKIP')
+provides=('ges-git')
+conflicts=('ges')
+
+pkgver() {
+
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+prepare()
+{
+
+ # Enter Package Source
+ cd "${pkgname}"
+
+ # Init submodules
+ git submodule init thirdparty/python
+ git config submodule.python.url ../python
+ git submodule update thirdparty/python
+
+ # Setup build environment
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+
+ mkdir build
+
+}
+
+build()
+{
+
+ cd "${pkgname}/build"
+ cmake -DCMAKE_INSTALL_PREFIX=${HOME}/.local/share/Steam/steamapps/sourcemods/gesource ..
+ make
+ make DESTDIR="${pkgdir}" install
+
+}
+
+package()
+{
+
+ # TODO
+ cd "${srcdir}/${pkgname}/build"
+ install -m 755 client.so "${pkgdir}"/usr/bin/
+ install -m 755 server.so "${pkgdir}"/usr/bin/
+
+}