summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD30
2 files changed, 16 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1db2f9d8dcce..d3dbe3a24f4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = get_iplayer-git
pkgdesc = Download TV and radio programmes from BBC iPlayer
- pkgver = 3.27.r3.gabd6c84
+ pkgver = 3.34.r0.g0cbb5bb
pkgrel = 1
url = https://github.com/get-iplayer/get_iplayer
arch = any
license = GPL3
makedepends = git
depends = perl-json-pp
- depends = perl-libwww
depends = perl-lwp-protocol-https
+ depends = perl-libwww
depends = perl-xml-libxml
+ depends = perl-mojolicious
optdepends = atomicparsley: metadata tagging for MP4 and M4A files
optdepends = ffmpeg: convert DASH audio/video, MPEG-TS, FLV files to MP4 and M4A
- optdepends = perl-mojolicious: reduce cache update time
+ optdepends = perl-cgi: web PVR manager
provides = get_iplayer
conflicts = get_iplayer
source = get_iplayer-git::git+https://github.com/get-iplayer/get_iplayer.git
diff --git a/PKGBUILD b/PKGBUILD
index 49fcb3aadf2b..95792a0171fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,30 +5,25 @@
# Contributor: canton7
pkgname=get_iplayer-git
-pkgver=3.27.r3.gabd6c84
+pkgver=3.34.r0.g0cbb5bb
pkgrel=1
-pkgdesc="Download TV and radio programmes from BBC iPlayer"
-arch=('any')
-url="https://github.com/get-iplayer/get_iplayer"
-license=('GPL3')
+pkgdesc='Download TV and radio programmes from BBC iPlayer'
+arch=(any)
+url=https://github.com/get-iplayer/get_iplayer
+license=(GPL3)
# perl-libwww is the LWP module
-depends=('perl-json-pp'
- 'perl-libwww'
- 'perl-lwp-protocol-https'
- 'perl-xml-libxml')
+depends=(perl-json-pp perl-lwp-protocol-https perl-libwww perl-xml-libxml perl-mojolicious)
optdepends=('atomicparsley: metadata tagging for MP4 and M4A files'
'ffmpeg: convert DASH audio/video, MPEG-TS, FLV files to MP4 and M4A'
- 'perl-mojolicious: reduce cache update time')
-makedepends=('git')
-provides=(${pkgname%-git})
-conflicts=(${pkgname%-git})
-source=($pkgname::git+$url.git)
+ 'perl-cgi: web PVR manager')
+makedepends=(git)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- git describe --match "v*" --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ git -C $pkgname describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
@@ -36,4 +31,3 @@ package() {
install -Dm644 $pkgname/README.md -t "$pkgdir/usr/share/doc/get_iplayer"
install -Dm644 $pkgname/get_iplayer.1 -t "$pkgdir/usr/share/man/man1"
}
-