summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f8e3825cd59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = getssl
+ pkgdesc = Obtain SSL certificates from the letsencrypt.org ACME server. Suitable for automating the process on remote servers.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/srvrco/getssl
+ arch = any
+ license = GPL2
+ makedepends = git
+ source = getssl::git+https://github.com/srvrco/getssl.git#tag=v1.0
+ sha256sums = SKIP
+
+pkgname = getssl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a56aa2e12845
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Karol Babioch <karol@babioch.de
+
+pkgname=getssl
+pkgver=1.0
+pkgrel=1
+pkgdesc='Obtain SSL certificates from the letsencrypt.org ACME server. Suitable for automating the process on remote servers.'
+arch=('any')
+url='https://github.com/srvrco/getssl'
+license=('GPL2')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/srvrco/getssl.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 getssl "$pkgdir/usr/bin/getssl"
+}
+