summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--ghidra.desktop9
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bd825028418
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ghidra-beta-bin
+ pkgdesc = Software reverse engineering framework (beta, bin)
+ pkgver = 9.1
+ pkgrel = 1
+ url = https://www.nsa.gov/ghidra
+ arch = x86_64
+ license = Apache
+ depends = java-environment>=11
+ depends = bash
+ provides = ghidra
+ conflicts = ghidra
+ source = https://ghidra-sre.org/ghidra_9.1-BETA_DEV_20190923.zip
+ source = https://raw.githubusercontent.com/NationalSecurityAgency/ghidra/master/LICENSE
+ source = ghidra.desktop
+ source = https://raw.githubusercontent.com/NationalSecurityAgency/ghidra/master/Ghidra/Framework/Generic/src/main/resources/images/GhidraIcon256.png
+ sha256sums = 3d61de711b7ea18bdee3ed94c31429e4946603b3e7d082cca5e949bbd651f051
+ sha256sums = c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4
+ sha256sums = 15b6fa386be85b23c879331e93124953cd724765248895a7e305c68ca698867c
+ sha256sums = 0e53f1b091046809c0f393326cadc69c27b1d574254e1094beedb312d09aa9c9
+
+pkgname = ghidra-beta-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df0b1ccf5b17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=ghidra-beta-bin
+pkgver=9.1
+_date=20190923
+pkgrel=1
+pkgdesc='Software reverse engineering framework (beta, bin)'
+arch=(x86_64)
+url=https://www.nsa.gov/ghidra
+license=(Apache)
+provides=(ghidra)
+conflicts=(ghidra)
+depends=('java-environment>=11' bash)
+source=(https://ghidra-sre.org/ghidra_${pkgver}-BETA_DEV_$_date.zip
+ https://raw.githubusercontent.com/NationalSecurityAgency/ghidra/master/LICENSE
+ ghidra.desktop
+ https://raw.githubusercontent.com/NationalSecurityAgency/ghidra/master/Ghidra/Framework/Generic/src/main/resources/images/GhidraIcon256.png)
+sha256sums=('3d61de711b7ea18bdee3ed94c31429e4946603b3e7d082cca5e949bbd651f051'
+ 'c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4'
+ '15b6fa386be85b23c879331e93124953cd724765248895a7e305c68ca698867c'
+ '0e53f1b091046809c0f393326cadc69c27b1d574254e1094beedb312d09aa9c9')
+
+package() {
+ install -d "$pkgdir"/{opt,usr/bin}
+ cp -a ghidra_$pkgver-BETA_DEV "$pkgdir"/opt/ghidra
+ ln -s /opt/ghidra/ghidraRun "$pkgdir"/usr/bin/ghidra
+ ln -s /opt/ghidra/support/analyzeHeadless "$pkgdir"/usr/bin/ghidra-headless
+
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/ghidra
+
+ install -Dm 644 ghidra.desktop -t "$pkgdir"/usr/share/applications
+ install -Dm 644 GhidraIcon256.png "$pkgdir"/usr/share/pixmaps/ghidra.png
+}
diff --git a/ghidra.desktop b/ghidra.desktop
new file mode 100644
index 000000000000..f5d46dc9f4a4
--- /dev/null
+++ b/ghidra.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Ghidra
+Comment=Software reverse engineering framework
+Exec=ghidra
+Icon=ghidra
+Categories=Utility;
+Terminal=false