summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8187082da196
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gigagram-git
+ pkgdesc = Gigagram combines webapps and websites into a single application.
+ pkgver = r38.8439cae
+ pkgrel = 1
+ url = https://github.com/sonnyp/gigagram
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = gjs
+ provides = gigagram
+ conflicts = gigagram
+ source = git+https://github.com/sonnyp/gigagram.git
+ sha256sums = SKIP
+
+pkgname = gigagram-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed2153ad17bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sonny Piers <sonny@fastmail.net>
+
+_name=gigagram
+pkgname=$_name-git
+pkgver=r38.8439cae
+pkgrel=1
+pkgdesc="Gigagram combines webapps and websites into a single application."
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/sonnyp/gigagram"
+license=('GPL3')
+depends=('gjs')
+makedepends=('git' 'meson')
+provides=($_name)
+conflicts=($_name)
+source=("git+https://github.com/sonnyp/$_name.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_name
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_name
+
+ meson --prefix=/usr/ build
+ ninja -C build
+}
+
+package(){
+ cd $_name
+
+ DESTDIR="$pkgdir" meson install -C build
+}