summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD15
3 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ed978dd1a66..249d784c00cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,13 +11,13 @@ pkgbase = git-chglog-bin
depends = git
provides = git-chglog
conflicts = git-chglog
- source_x86_64 = git-chglog-0.15.4.tar.gz::https://github.com/git-chglog/git-chglog/releases/download/v0.15.4/git-chglog_0.15.4_linux_amd64.tar.gz
+ source_x86_64 = https://github.com/git-chglog/git-chglog/releases/download/v0.15.4/git-chglog_0.15.4_linux_amd64.tar.gz
sha256sums_x86_64 = 03cbeedbd1317289295e75016fa0acd26baeb2fc7810ed287361dd9bd8bc33a8
- source_i686 = git-chglog-0.15.4.tar.gz::https://github.com/git-chglog/git-chglog/releases/download/v0.15.4/git-chglog_0.15.4_linux_386.tar.gz
+ source_i686 = https://github.com/git-chglog/git-chglog/releases/download/v0.15.4/git-chglog_0.15.4_linux_386.tar.gz
sha256sums_i686 = 14e0109131f6e897cbc0878a15e3c476ee23745e7a9a9fd8a487af6c11e62ba1
- source_aarch64 = git-chglog-0.15.4.tar.gz::https://github.com/git-chglog/git-chglog/releases/download/v0.15.4/git-chglog_0.15.4_linux_arm64.tar.gz
+ source_aarch64 = https://github.com/git-chglog/git-chglog/releases/download/v0.15.4/git-chglog_0.15.4_linux_arm64.tar.gz
sha256sums_aarch64 = 75d6fcfe1e2f7335a37048e01db53b87035a11ab78a8c3fc2ba65a6e5794f71f
- source_armv6h = git-chglog-0.15.4.tar.gz::https://github.com/git-chglog/git-chglog/releases/download/v0.15.4/git-chglog_0.15.4_linux_armv6.tar.gz
+ source_armv6h = https://github.com/git-chglog/git-chglog/releases/download/v0.15.4/git-chglog_0.15.4_linux_armv6.tar.gz
sha256sums_armv6h = 79efbebc1327e91334decb3be51094f3e430928fcc25512b5b963864f1da0b9d
pkgname = git-chglog-bin
diff --git a/.gitignore b/.gitignore
index 6e9bafca4a72..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,4 @@
-*.tar.*
-*.orig
-*.rej
-*.swp
-*.part
-src
-pkg
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index d0b49ab70c08..b2aa48d2ad08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: vitaliikuzhdin <vitaliikuzhdin@gmail.com>
-_pkgname=git-chglog
-pkgname=${_pkgname}-bin
+_pkgname="git-chglog"
+pkgname="${_pkgname}-bin"
pkgver=0.15.4
pkgrel=1
pkgdesc="git CHANGELOG generator"
@@ -9,13 +9,12 @@ arch=('x86_64' 'i686' 'aarch64' 'armv6h')
url="https://github.com/${_pkgname}/${_pkgname}"
license=('MIT')
depends=('git')
-conflicts=("${_pkgname}")
provides=("${_pkgname}")
-_pkgsrc="${_pkgname}-${pkgver}"
-source_x86_64=("${_pkgsrc}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.tar.gz")
-source_i686=("${_pkgsrc}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_386.tar.gz")
-source_aarch64=("${_pkgsrc}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.tar.gz")
-source_armv6h=("${_pkgsrc}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_armv6.tar.gz")
+conflicts=("${_pkgname}")
+source_x86_64=("${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.tar.gz")
+source_i686=("${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_386.tar.gz")
+source_aarch64=("${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.tar.gz")
+source_armv6h=("${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_armv6.tar.gz")
sha256sums_x86_64=('03cbeedbd1317289295e75016fa0acd26baeb2fc7810ed287361dd9bd8bc33a8')
sha256sums_i686=('14e0109131f6e897cbc0878a15e3c476ee23745e7a9a9fd8a487af6c11e62ba1')
sha256sums_aarch64=('75d6fcfe1e2f7335a37048e01db53b87035a11ab78a8c3fc2ba65a6e5794f71f')