summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8b6c6cd3d71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = git-explode
+ pkgdesc = Explode linear sequence of git commits into topic branches
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/aspiers/git-explode
+ arch = any
+ license = GPL2
+ depends = git
+ depends = git-deps
+ depends = python
+ depends = python-ostruct
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/g/git-explode/git-explode-0.0.1.tar.gz
+ sha512sums = 49513e4ca5c1212b1fd2a5671d988c1fdc0644d9e5477acc5b5404fdd3af1390d01826edb72824511f3b93a2628bed762f44658c031ea4e7f948cc217ccd6764
+
+pkgname = git-explode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..268369a67ebc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=git-explode
+depends=(git git-deps python python-ostruct python-setuptools)
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Explode linear sequence of git commits into topic branches'
+arch=(any)
+url=https://github.com/aspiers/git-explode
+license=(GPL2)
+source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz)
+sha512sums=('49513e4ca5c1212b1fd2a5671d988c1fdc0644d9e5477acc5b5404fdd3af1390d01826edb72824511f3b93a2628bed762f44658c031ea4e7f948cc217ccd6764')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 README.rst "$pkgdir/usr/share/doc/$pkgname/README"
+}
+
+# Depends on having the git repo instead of just the source tarball.
+#
+#checkdepends=(python-pytest python-pytest-cov)
+#check() {
+# cd "$srcdir/$pkgname-$pkgver"
+# python setup.py test
+#}