summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..789d7900a2fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = git-fat-git
+ pkgdesc = Simple way to handle fat files without committing them to git
+ pkgver = r84.d5b388c
+ pkgrel = 1
+ url = https://github.com/jedbrown/git-fat
+ arch = any
+ license = BSD
+ depends = git
+ depends = rsync
+ depends = python2
+ source = git+https://github.com/jedbrown/git-fat.git
+ md5sums = SKIP
+
+pkgname = git-fat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89373751f1c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: matmoser@wu.ac.at
+
+pkgname=git-fat-git
+pkgver=r84.d5b388c
+pkgrel=1
+pkgdesc="Simple way to handle fat files without committing them to git"
+arch=('any')
+url="https://github.com/jedbrown/git-fat"
+license=('BSD')
+depends=('git' 'rsync' 'python2')
+source=("git+https://github.com/jedbrown/git-fat.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ # fix shebang
+ sed -i '1s|env python$|&2|g' ${pkgname%-*}/git-fat
+}
+
+package() {
+ cd ${pkgname%-*}
+
+ install -Dm0755 git-fat "$pkgdir"/usr/bin/git-fat
+ install -Dm0644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm0644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+}