summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--fix-find-flag.patch14
3 files changed, 8 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08c0c5bca601..4527b719150d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Mar 9 07:20:57 UTC 2016
+# Wed Mar 8 13:20:34 UTC 2017
pkgbase = git-hooks-git
pkgdesc = A tool to manage project, user, and global Git hooks for multiple git repositories.
- pkgver = 1.00.0.r9.g3b89627
- pkgrel = 2
+ pkgver = 1.00.0.r22.ge5ac866
+ pkgrel = 1
url = https://github.com/icefox/git-hooks
arch = any
license = BSD
@@ -12,9 +12,7 @@ pkgbase = git-hooks-git
provides = git-hooks
conflicts = git-hooks
source = git+https://github.com/icefox/git-hooks
- source = fix-find-flag.patch
sha256sums = SKIP
- sha256sums = b4a4e8543365b98e74abfaf66fffcd9be1dbc8fdacf538a2f800e49dfebee48e
pkgname = git-hooks-git
diff --git a/PKGBUILD b/PKGBUILD
index dc87a483f29d..f4140da11187 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Sebastian Reuße <seb@wirrsal.net>
pkgname=git-hooks-git
_gitname=git-hooks
-pkgver=1.00.0.r9.g3b89627
-pkgrel=2
+pkgver=1.00.0.r22.ge5ac866
+pkgrel=1
pkgdesc="A tool to manage project, user, and global Git hooks for multiple git repositories."
arch=(any)
url="https://github.com/icefox/git-hooks"
@@ -11,14 +11,9 @@ depends=(git)
makedepends=(git)
provides=(git-hooks)
conflicts=(git-hooks)
-source=(
- git+https://github.com/icefox/git-hooks
- fix-find-flag.patch
-)
-sha256sums=(
- SKIP
- b4a4e8543365b98e74abfaf66fffcd9be1dbc8fdacf538a2f800e49dfebee48e
-)
+source=(git+https://github.com/icefox/git-hooks)
+sha256sums=(SKIP)
+
pkgver() {
cd "$_gitname"
@@ -26,13 +21,6 @@ pkgver() {
sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- # Since upstream appears dormant, we have to fix the deprecated find syntax
- # here, for now. Cf. https://github.com/icefox/git-hooks/pull/46
- cd "$_gitname"
- patch <"$startdir/fix-find-flag.patch"
-}
-
package() {
cd "$_gitname"
install -D git-hooks "$pkgdir"/usr/bin/git-hooks
diff --git a/fix-find-flag.patch b/fix-find-flag.patch
deleted file mode 100644
index 834152507648..000000000000
--- a/fix-find-flag.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- git-hooks 2016-03-09 08:15:21.789661336 +0100
-+++ git-hooks 2016-03-09 08:15:08.707175377 +0100
-@@ -52,9 +52,9 @@
- level="${2}"
- find --help 2>&1 | grep -- '-L' 2>/dev/null >/dev/null
- if [ $? -eq 1 ] ; then
-- find "${path}/" -mindepth ${level} -maxdepth ${level} -perm +111 -type f 2>/dev/null | grep -v "^.$" | sort
-+ find "${path}/" -mindepth ${level} -maxdepth ${level} -perm /111 -type f 2>/dev/null | grep -v "^.$" | sort
- else
-- find -L "${path}/" -mindepth ${level} -maxdepth ${level} -perm +111 -type f 2>/dev/null | grep -v "^.$" | sort
-+ find -L "${path}/" -mindepth ${level} -maxdepth ${level} -perm /111 -type f 2>/dev/null | grep -v "^.$" | sort
- fi
- }
-