summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d28d052cb88..26e71fdf930a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = git-it
pkgdesc = Desktop app that teaches you how to use Git and GitHub on the command line.
- pkgver = 4.4.0
+ pkgver = 5.2.2
pkgrel = 1
- url = https://github.com/jlord/git-it-electron
+ url = https://github.com/Git-it-App/git-it-electron
arch = x86_64
license = BSD
depends = gnuplot
@@ -12,18 +12,18 @@ pkgbase = git-it
depends = nodejs
depends = nss
depends = gconf
- provides = git-it
- noextract = Git-it-Linux-x64-4.4.0.zip
+ depends = gtk2
+ depends = git
+ noextract = Git-it-linux-x64-5.2.2.zip
options = !strip
- source = Git-it-Linux-x64-4.4.0.zip::https://github.com/jlord/git-it-electron/releases/download/4.4.0/Git-it-Linux-x64.zip
+ source = Git-it-linux-x64-5.2.2.zip::https://github.com/Git-it-App/git-it-electron/releases/download/v5.2.2/Git-it-linux-x64.zip
source = git-it.desktop
source = git-it.png
- md5sums = fb378d059f62249de5336366b9cb5980
+ md5sums = 9bc834a44f3ab3535f29fe4e9c3d71b5
md5sums = cc6162296991cdb4463081962c0018f1
md5sums = 3fc4074dd6efa11246481d57dae86cf1
- sha256sums = 02b238984729632aadf5640454e9b0061a0b7301e7d0a704b1ba01708b225e80
+ sha256sums = d207e6da47c1987fdbf1165f05d287f83197aa6eaca63d2c34bd7b9a60a92269
sha256sums = 2ad08e42d2774e746c2730bcc90f089e2e97ad7c79875a52c3d341ad75affdfc
sha256sums = 55ff797c3449f24f5e53186f3e08aacd98b832b7191b8893c2d7b26b52e2a375
pkgname = git-it
-
diff --git a/PKGBUILD b/PKGBUILD
index 81ef3e8886ad..c09c7e413c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,39 @@
set -u
pkgbase='git-it'
pkgname='git-it'
-pkgver='4.4.0'
+pkgver='5.2.2'
pkgrel='1'
pkgdesc='Desktop app that teaches you how to use Git and GitHub on the command line.'
arch=('x86_64')
-url='https://github.com/jlord/git-it-electron'
+#url='https://github.com/jlord/git-it-electron'
+url='https://github.com/Git-it-App/git-it-electron'
license=('BSD')
depends=('gnuplot' 'libxtst' 'libxss' 'alsa-lib' 'nodejs' 'nss' 'gconf')
-provides=('git-it')
+depends+=('gtk2' 'git')
+#provides=('git-it')
options=('!strip')
-_file="Git-it-Linux-x64-${pkgver}.zip"
+_srcdir='Git-it-linux-x64'
+_file="${_srcdir}-${pkgver}.zip"
source=(
- "${_file}::https://github.com/jlord/git-it-electron/releases/download/${pkgver}/Git-it-Linux-x64.zip"
+ "${_file}::${url}/releases/download/v${pkgver}/${_srcdir}.zip"
"${pkgname}.desktop"
"${pkgname}.png"
)
noextract=("${_file}")
-md5sums=('fb378d059f62249de5336366b9cb5980'
+md5sums=('9bc834a44f3ab3535f29fe4e9c3d71b5'
'cc6162296991cdb4463081962c0018f1'
'3fc4074dd6efa11246481d57dae86cf1')
-sha256sums=('02b238984729632aadf5640454e9b0061a0b7301e7d0a704b1ba01708b225e80'
+sha256sums=('d207e6da47c1987fdbf1165f05d287f83197aa6eaca63d2c34bd7b9a60a92269'
'2ad08e42d2774e746c2730bcc90f089e2e97ad7c79875a52c3d341ad75affdfc'
'55ff797c3449f24f5e53186f3e08aacd98b832b7191b8893c2d7b26b52e2a375')
-PKGEXT='.tar.gz'
package() {
set -u
install -d "${pkgdir}/opt/"
bsdtar --no-same-owner -C "${pkgdir}/opt/" -xf "${_file}"
- mv "${pkgdir}/opt"/{Git-it-Linux-x64,git-it}
+ mv "${pkgdir}/opt"/{"${_srcdir}",'git-it'}
+ chmod 755 "${pkgdir}/opt/git-it/Git-it"
install -d "${pkgdir}/usr/bin"
ln -s '/opt/git-it/Git-it' "${pkgdir}/usr/bin/git-it"