summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--gitd.install8
3 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07a4c9b6d229..c7f2bd6919f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = gitd
pkgdesc = A way of notifying you of git commits
- pkgver = 0.2.0
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/benjamin-james/gitd
+ install = gitd.install
arch = any
license = GPL3
makedepends = autoconf
@@ -10,8 +11,8 @@ pkgbase = gitd
depends = glibc
optdepends = libnotify: the default notifier for gitd through notify-send
provides = gitd
- source = https://github.com/benjamin-james/gitd/releases/download/0.2.0/gitd-0.2.0.tar.xz
- md5sums = 2cbd1094d858658ddef3ddba312101c3
+ source = https://github.com/benjamin-james/gitd/releases/download/0.4.0/gitd-0.4.0.tar.xz
+ md5sums = bc8fd8785c73f758b807e0116a586bb6
pkgname = gitd
diff --git a/PKGBUILD b/PKGBUILD
index a2e1c44211a4..caa78ae8ffdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Benjamin James <benjamin-james@utulsa.edu>
pkgname=gitd
-pkgver=0.2.0
+pkgver=0.4.0
pkgrel=1
pkgdesc="A way of notifying you of git commits"
arch=('any')
url="https://github.com/benjamin-james/gitd"
license=('GPL3')
+install='gitd.install'
depends=('git' 'glibc')
makedepends=('autoconf')
optdepends=('libnotify: the default notifier for gitd through notify-send')
provides=('gitd')
source=(https://github.com/benjamin-james/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz)
-md5sums=('2cbd1094d858658ddef3ddba312101c3')
+md5sums=('bc8fd8785c73f758b807e0116a586bb6')
build() {
cd "${pkgname}"
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc
+ autoreconf -i
+ ./configure --prefix=/usr --sysconfdir=/etc/gitd/
make
}
diff --git a/gitd.install b/gitd.install
new file mode 100644
index 000000000000..5c4e030ecedb
--- /dev/null
+++ b/gitd.install
@@ -0,0 +1,8 @@
+post_install() {
+cat << EOF
+To use this program, please check /etc/gitd/gitd.conf and configure it using your preferred notification program. Also, you have to have a notification server running in order for the notifications to be caught, and many DE's support this natively. See https://wiki.archlinux.org/index.php/Desktop_notifications for more details on this. In order for the program to start, one has to let systemd know about gitd. Type
+ systemctl enable gitd.service
+ systemctl start gitd.service
+to complete the installation. For more information, see gitd(8)
+EOF
+}