summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD27
-rw-r--r--lxc_update.patch46
4 files changed, 74 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 660197d7769f..1ef167a0f06a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gitlab-runner-custom-executors
pkgdesc = The official GitLab CI runner written in Go with a LXC Executor
- pkgver = 9.2.0
- pkgrel = 3
+ pkgver = 9.5.0
+ pkgrel = 1
url = https://gitlab.com/gitlab-org/gitlab-ci-multi-runner
install = gitlab-runner.install
arch = i686
@@ -17,27 +17,29 @@ pkgbase = gitlab-runner-custom-executors
depends = git
depends = glibc
depends = tar
- provides = gitlab-runner=9.2.0-3
+ provides = gitlab-runner=9.5.0-1
conflicts = gitlab-runner
- noextract = prebuilt-x86_64.tar.xz
- noextract = prebuilt-arm.tar.xz
+ noextract = prebuilt-9.5.0-x86_64.tar.xz
+ noextract = prebuilt-9.5.0-arm.tar.xz
backup = etc/gitlab-runner/config.toml
- source = git+https://gitlab.com/gitlab-org/gitlab-ci-multi-runner.git#tag=v9.2.0
- source = https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/master/docker/prebuilt-x86_64.tar.xz
- source = https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/master/docker/prebuilt-arm.tar.xz
+ source = git+https://gitlab.com/gitlab-org/gitlab-ci-multi-runner.git#tag=v9.5.0
+ source = prebuilt-9.5.0-x86_64.tar.xz::https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/v9.5.0/docker/prebuilt-x86_64.tar.xz
+ source = prebuilt-9.5.0-arm.tar.xz::https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/v9.5.0/docker/prebuilt-arm.tar.xz
source = gitlab-runner.service
source = gitlab-runner.sysusers
source = gitlab-runner.tmpfiles
source = config.toml
source = lxc_executor.patch
+ source = lxc_update.patch
sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
+ sha512sums = da953698b2656d5d85a77891a3944951c8099ea61533b6c600d867edb4bb9ee90c799aadb46eb1509abee2810f98a511e20bb8f61adfce0b6c2cb008db1fc1b8
+ sha512sums = 49ae61727a98082adfc6b0b9fd5b108fc7981f4628dc20a6dd6136102b9e17f3877ad61efff51e2ef3e7da40e01571dd2f94849fb120bec55ba028542751569c
sha512sums = ed24841242a56a3b10dd80cd23e0c980f6bbe5fd0ebd4c6b46529947e4920cc9c03e4f4b239da8a798c801a6cdd757415113f97e45c1032f2c519fdaec4d3ae0
sha512sums = 8aa7f08702e99053c696fcc2aaba83beb9e9cd6f31973d82862db9350ac46df3a095377625d31fe909677525290d2de922d7a97930ed235774cb8f0da8944d40
sha512sums = 6751d9fa0b27172d1b419c4138f5ac15cbc7c9147653a7258cf1470216142c637210bb60608c7ed0974e0e4057e5ddeae32225df1bb36e7dd1f20fec71e33cc3
sha512sums = f39c23fc06636f31c3fadb9a630c54527e8255098f18d275772cb30875d0a7463717101704070d432f2b69ab71f076a9538172a439bc307722dad2c7e260f752
sha512sums = f88b8e6a8afb4f11bf61cfb6f680f611946658a8ea9c31588fb0b4be505bc72ac1af30ce819a2e74631d47919d684f121a625c091b3e6e891df5c434ae04acff
+ sha512sums = 8253422afbb51431b93c54d106c61a19821d2e1ee27eb5ade5f1eeb7c2575df3ed6452cf71ed2bc9a1d185302065eea1361b7aa8d239515ee32a01212153dd93
pkgname = gitlab-runner-custom-executors
diff --git a/.gitignore b/.gitignore
index a9eb70d24404..d1a6f887f23f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,5 +7,6 @@
!gitlab-runner.sysusers
!gitlab-runner.tmpfiles
!lxc_executor.patch
+!lxc_update.patch
!PKGBUILD
!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index b916258bd62b..283deafe2546 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Custom Executor Maintainer: Marc Mettke <marc@itmettke.de>
pkgname=gitlab-runner-custom-executors
-pkgver=9.2.0
-pkgrel=3
+pkgver=9.5.0
+pkgrel=1
pkgdesc="The official GitLab CI runner written in Go with a LXC Executor"
arch=('i686' 'x86_64')
url='https://gitlab.com/gitlab-org/gitlab-ci-multi-runner'
@@ -13,29 +13,31 @@ depends=('ca-certificates' 'curl' 'git' 'glibc' 'tar')
makedepends=('git' 'go' 'git' 'go-bindata' 'mercurial')
install='gitlab-runner.install'
backup=('etc/gitlab-runner/config.toml')
-noextract=('prebuilt-x86_64.tar.xz'
- 'prebuilt-arm.tar.xz')
+noextract=("prebuilt-${pkgver}-x86_64.tar.xz"
+ "prebuilt-${pkgver}-arm.tar.xz")
provides=("${pkgname/-custom-executors}=${pkgver}-${pkgrel}")
conflicts=("${pkgname/-custom-executors}")
# Note: This should be built using git because the runner gets its version information from there and I
# haven't found the place to patch that yet.
source=("git+https://gitlab.com/gitlab-org/gitlab-ci-multi-runner.git#tag=v${pkgver}"
- "https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/master/docker/prebuilt-x86_64.tar.xz"
- "https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/master/docker/prebuilt-arm.tar.xz"
+ "prebuilt-${pkgver}-x86_64.tar.xz::https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/v${pkgver}/docker/prebuilt-x86_64.tar.xz"
+ "prebuilt-${pkgver}-arm.tar.xz::https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/v${pkgver}/docker/prebuilt-arm.tar.xz"
"gitlab-runner.service"
"gitlab-runner.sysusers"
"gitlab-runner.tmpfiles"
"config.toml"
- "lxc_executor.patch")
+ "lxc_executor.patch"
+ "lxc_update.patch")
sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
+ 'da953698b2656d5d85a77891a3944951c8099ea61533b6c600d867edb4bb9ee90c799aadb46eb1509abee2810f98a511e20bb8f61adfce0b6c2cb008db1fc1b8'
+ '49ae61727a98082adfc6b0b9fd5b108fc7981f4628dc20a6dd6136102b9e17f3877ad61efff51e2ef3e7da40e01571dd2f94849fb120bec55ba028542751569c'
'ed24841242a56a3b10dd80cd23e0c980f6bbe5fd0ebd4c6b46529947e4920cc9c03e4f4b239da8a798c801a6cdd757415113f97e45c1032f2c519fdaec4d3ae0'
'8aa7f08702e99053c696fcc2aaba83beb9e9cd6f31973d82862db9350ac46df3a095377625d31fe909677525290d2de922d7a97930ed235774cb8f0da8944d40'
'6751d9fa0b27172d1b419c4138f5ac15cbc7c9147653a7258cf1470216142c637210bb60608c7ed0974e0e4057e5ddeae32225df1bb36e7dd1f20fec71e33cc3'
'f39c23fc06636f31c3fadb9a630c54527e8255098f18d275772cb30875d0a7463717101704070d432f2b69ab71f076a9538172a439bc307722dad2c7e260f752'
- 'f88b8e6a8afb4f11bf61cfb6f680f611946658a8ea9c31588fb0b4be505bc72ac1af30ce819a2e74631d47919d684f121a625c091b3e6e891df5c434ae04acff')
+ 'f88b8e6a8afb4f11bf61cfb6f680f611946658a8ea9c31588fb0b4be505bc72ac1af30ce819a2e74631d47919d684f121a625c091b3e6e891df5c434ae04acff'
+ '8253422afbb51431b93c54d106c61a19821d2e1ee27eb5ade5f1eeb7c2575df3ed6452cf71ed2bc9a1d185302065eea1361b7aa8d239515ee32a01212153dd93')
prepare() {
mkdir -p "${srcdir}/src/gitlab.com/gitlab-org/"
@@ -44,14 +46,15 @@ prepare() {
msg "Patch add lxc Executor"
patch -Np1 -i "${srcdir}/lxc_executor.patch"
+ patch -Np1 -i "${srcdir}/lxc_update.patch"
make version
export GOPATH="${srcdir}"
make deps
- ln -sf "${srcdir}/prebuilt-x86_64.tar.xz" prebuilt-x86_64.tar.xz
- ln -sf "${srcdir}/prebuilt-x86_64.tar.xz" prebuilt-arm.tar.xz
+ ln -sf "${srcdir}/prebuilt-${pkgver}-x86_64.tar.xz" prebuilt-x86_64.tar.xz
+ ln -sf "${srcdir}/prebuilt-${pkgver}-x86_64.tar.xz" prebuilt-arm.tar.xz
}
build() {
diff --git a/lxc_update.patch b/lxc_update.patch
new file mode 100644
index 000000000000..afcbc45aedd5
--- /dev/null
+++ b/lxc_update.patch
@@ -0,0 +1,46 @@
+From c76d327a063514935696b7db321e42854cd55d08 Mon Sep 17 00:00:00 2001
+From: Xavier Leune <xleune@ccmbenchmark.com>
+Date: Mon, 24 Jul 2017 14:44:26 +0200
+Subject: [PATCH] Update to new struct
+
+---
+ executors/lxc/executor_lxc.go | 9 ++++-----
+ 1 file changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/executors/lxc/executor_lxc.go b/executors/lxc/executor_lxc.go
+index f043efb..73af6b6 100644
+--- a/executors/lxc/executor_lxc.go
++++ b/executors/lxc/executor_lxc.go
+@@ -13,8 +13,8 @@ type executor struct {
+ command lxc.Client
+ }
+
+-func (e *executor) Prepare(globalConfig *common.Config, config *common.RunnerConfig, build *common.Build) error {
+- err := e.AbstractExecutor.Prepare(globalConfig, config, build)
++func (e *executor) Prepare(options common.ExecutorPrepareOptions) error {
++ err := e.AbstractExecutor.Prepare(options)
+ if err != nil {
+ return err
+ }
+@@ -33,8 +33,8 @@ func (e *executor) Prepare(globalConfig *common.Config, config *common.RunnerCon
+ // Create LXC command
+ e.command = lxc.Client{
+ Config: *e.Config.LXC,
+- Stdout: e.BuildTrace,
+- Stderr: e.BuildTrace,
++ Stdout: e.Trace,
++ Stderr: e.Trace,
+ }
+
+ e.Debugln("Connecting to LXC server...")
+@@ -50,7 +50,6 @@ func (e *executor) Run(cmd common.ExecutorCommand) error {
+ Environment: e.BuildShell.Environment,
+ Command: e.BuildShell.GetCommandWithArguments(),
+ Stdin: cmd.Script,
+- Abort: cmd.Abort,
+ })
+ return err
+ }
+--
+libgit2 0.26.0
+